We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

[Request] Kernel module kmod-cryptodev

  • What I have tried:

    • With my docker project I have successfully compiled libraries like gmp-lib compatible with the official omega2 firmware.
    • Also compiled new firmware where this kernel module works perfectly.

    The problems are:

    • Compiling the kernel module as a package didn't work because the linux kernel versions from the official firmware and the Lede repository don't match. Changing the include/kernel-version file to change the kernel 4.4 version to the 4.4.36 (the official firmware's version), still didn't work (I think the error message said something about version 4.4.26-1, and I don't know how to chek, nor change the -1 part).
    • The custom firmware has very poor wifi performance (also a tutorial on how to connect to other wifi ap's without wifisetup would be nice, all I achived was the omega2's ap, with the poor performance).
    • Adding the OnionIoT OpenWRT-Packages;omega2 feeds gave me recursive dependencies with onion-console-terminal (even when not selected) , and selecting the ralink wifi driver does not seem to work. Maybe I have to configure /etc/config/wireless to use the driver, but don't know how. A bit more documentation would be great.
    • I couldn't compile @WereCatf 's project (still trying) for a custom firmware with more friendly network setup.

    My requests:

    • Anyone knows what else I have to change to properly compile the kernel module for the official omega2 firmware kernel version?
    • Could the @administrators compile it or/and add it to the repository?
    • Could the @administrators provide the config and files for their SDK? Building custom firmware is a nightmare nowadays.

    Edit 1: About WereCatf 's firmware

    Seems like docker file system is not 100% compatible with this big development systems (confdir3 deep directories are a thing in many other projects with docker). Tried with a virtual machine and it compiled succesfully, even with the recursive dependencies. Sysupgrade doesn't complain anymore, but I got a kernel panic (maybe the extra kernel modules I added). Will try with vanilla WereCatf's source.

    Edit 2: WereCatf 's firmware works

    The kernel panic was because of the Ralink driver in the feed OnionIoT OpenWRT-Packages. Deselecting it in make menuconfig fixed it.
    Another note in WereCatf's firmware is that in my case, using first_time_setup.sh, after the make menuconfig _exit & save`, everything related to Luci was deselected, so no web interface in the first build. Reselecting as in WereCatf's .config file worked like a charm.

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.