We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

[Resolved] What we have here is a failure to communicate...

  • Somehow in the process of trying to fix a problem I've caused an even bigger one. My Omega2+ has two entries listed when I run the " ls -all" command in SSH. This could potentially explain why whenever I attempt to connect via console the only thing that happens after logging in is watching the gear icon spin into oblivion (aka a white screen). Any advice?

    Also, apologies in advance, I am about to go to sleep and then work after, so I won't respond to anything until about 16:30 MDT.

  • ls --all from where? /? /root? /www?
    If you have SSH access, reinstall the onion console package with opkg, assuming your problem is that you deleted it's files.

  • @Andrew-Marshall I think you mean ls --all, otherwise you specify two times the l option :-). You can also use ls -a as a shortcut.
    Now to your Problem. ls -a lists at least two items: . and ..
    . is the current directory and
    .. is the parent directory
    Typically if you connect through ssh your working directory is the home directory of the user you're logged in. Mostly root on omega2. That menas you start in /root as your working directory. If you haven't copied anything to this place it should be empty and ls -al returns just these two directories.

    root@omega:~ ls -a
    . ..

    you may change the directory to the root (root of filesystem, not home directory of root, the difference is / and /root/) by executing

    cd /

    I hope it helps

    Edit: I forget your other problem. Do you use an adblocker, scriptblocker or anything like that? I had to allow the omega2 in noScript (firefox plugin) to open the omega console

  • @José-Luis-Cánovas Upon connecting via SSH and accessing BusyBox (v1.26.2), my commands are prefixed with "root@Omega-XXXX:~#"

  • @Christopher Spot on, running that command gave me exactly what you predicted.

    I tried running "opkg" but it wasn't happy with that, and broke out a bunch of options for commands. I tried running "update" but that wasn't successful.

    Any advice? Making progress, but still a touch lost.

  • Guys, this one is closed. I am just an idiot and didn't properly follow through with some of the pre-existing solved threads. Thanks for helping me and making me realize that I might be able to fix this myself!

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.