We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

wifi broken on startup?

  • I am trying to follow the instructions on the getstarted page but I have two issues.

    1. I have to continuously hold the omega onion onto the dock otherwise it pops out. Super annoying.

    2. I can do all 5 steps of "preparing hardware" but it does not show up on the wi-fi list like it should on step 1 of the "setting up using GUI"

    My question to everyone else is. Should I have to hold them together with a rubber band? or does it "snap" in with a hard push. I feel if I squeeze them together any harder and it could break the board. And my next question is there anything not listed in the get started steps that would turn on the wifi? or is it possible I have a broken device?

  • Okay. I think the wifi issue is related to the bad physical connection between the dock and the onion. I have to hold them together suuuuuper hard. I now have perforated my fingertips because I don't want to push on the middle of the board. Is this normal anyone? or is everyone able to just drop the onion right into the dock without any fuss?

  • Hi Jeremy,

    I didn't use the Webinterface to configure the network, so I cannot answer that question, sorry. I only had the "problem" that my local network uses 192.168.3.x as addresses as well, therefor I changed /etc/config/network so that the Omega uses 192.168.4.x as his network. As I've worked with OpenWRT for some time now that was nothing blocking me… but maybe for others it would be good to know.
    But for the hardware: My device sticks just fine to the Expansion Dock. Maybe some of your pins are damaged? Or is the Expansion Dock bent?
    The only "problem" with the hardware I have is that sometimes the Omega reboots when I lift it. But maybe that's the MicroUSB cable I'm using.


  • Hi Frank,
    I have no problem logging onto the onion gui once I connect to it via wi-fi but I am now concerned with my hardware. I just opened the package and it's disconcerting that I cannot connect the dock (i have a mini dock) to the onion without holding it down.

  • @Jeremy-Jones Hi Jeremy, so sorry about the defect. Would you be able to upload a picture of how the Omega is popping out of the dock? We will send you a replacement.

  • Hi Jeremy,

    sorry, my connection to this forum seems to be quite slow. I wrote the answer before you wrote that you could use the WiFi. πŸ˜‰


  • Hi Broken Lin,

    Thanks for the reply. The pins look good in this pic so maybe the issue is with the dock.

    When I let go of the onion after connecting to the dock it will always pop out slightly and the only way for me to keep them connected is to hold it down. As demonstrated here: without holding and with holding

  • @Jeremy-Jones Hi Jeremy, it looks like the header on the dock is bent outward. Can you try this: if you have a plier, can you try to bend the header a bit toward the center of the PCB? Please let me know if this helps at all.

  • @Boken-Lin I'll try this when I get home. Thank you.

  • @Boken-Lin Hi Boken, So I tried doing as you suggested and I can get it to connect without me holding it. But if I bump it or any other small movement and it will pop out. I don't want to bend it anymore for fear of permanently damaging the board or the Onion.

    What is the next course of action?

  • @Jeremy-Jones Try bending it it even more. If it breaks, we'll be sending you a replacement anyways πŸ™‚

  • @Boken-Lin So, after fiddling with it for a couple days, I think I might need a replacement. I just can't get it aligned perfectly. I think the onion itself is fine and just the dock needs to be replaced. should I send both back for you guys to take a look? I am assuming this is not the forum to process this. What is the process?

  • @Jeremy-Jones Can you send us a message on the Kickstarter Message system? We will take it from there. Thanks for trying it out!

  • Okay. Thank you for your help.

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.