We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Serial connection to Omega2+ using a USB to serial CP2102 adapters

  • I recently bricked my Omega2+, as many others, using a bad firmware.

    As I only own the Power Dock, I have no serial connector on board, so I bought a USB to serial CP2102 adapter.

    Now I've tried connecting the adapter to the 5V, GND, RX1 and TX1 on the Power Dock, seeing the power led on the board and on the Omega2+. But I couldn't connect to COM3 using Putty. I then tried to connect to 3.3V (switching from 5V to 3.3V on the adapter as well), still no luck. I then tried connecting directly to the Omega2+ using the pin annotation listed here.I tried GPIO 12, 13 for serial and then GPIO 45, 46. But all I get from Putty is a communication error.

    Am I doing something completely wrong, or is my Omega2+ completely bricked?

  • @Håvard-Bartnes
    Set the adapter's power to 3.3V.
    the adapter's Tx to Omega's (Serial--RX0--13) and
    the adapter's Rx to Omega's (Serial--TX0--12) labeled pin.
    GND to GND

    PuTTY Configuration:
    Connection type: Serial
    Serial line: COMx (choose the right one)
    Speed: 115200
    Data bits: 8
    Stop bits: 1
    Parity: None
    Flow control: None

    Maybe your Omega is bricked but the serial terminal should work.
    Good luck!

  • What should be clarified here is that neither the adapters 3.3v pin nor its 5v pin should be connected to the Omega 2.

Looks like your connection to Community was lost, please wait while we try to reconnect.