We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Use the yellow blinking LED to help troubleshooting

  • There are far too many power related issues masquerading as

    • boot loop
    • not working
    • no WiFi access point detected
    • mine is DOA

    Many can be traced into insufficient power supply issues.

    Please check the following timing

    • about 1.5 second after power is applied, Omega 2's yellow LED starts to lit constantly
    • about 8.5 second after power is applied, yellow LED starts to blink
    • about 22 second after power is applied, if you see that yellow LED stops blinking and turns off
      --> you have a power issue

    If not, (continues blinking), your Omega 2 is okay-ish, from power supply point of view.

    That 22 seconds into the boot process is a critical point where the WiFi related electronics kicks in.
    It all in sudden created a high-demanding inrush current need, which in turn can drop the Omega 2's
    input supply voltage below the minimal required thus causing the "brown out" condition.

    I hope this simple test step will help.


  • I can't find any post about the situation I am facing, the led lights up after half a second but never blinks. I'm using an arduino dock 2 with an Omega 2+, no SD card, no other connection than micro USB (with the supplied cable, tried on several computers and other cables that work with my phone).

    I can see the wifi signal, I can log on IP as root and pw onioneer but when I select my wifi and WPA code it fails to connect.
    That's about all I can say for now, please let me know if any other information would reveal useful.

    My Mac does not see any USB device so the terminal cannot be used to access command line mode (driver properly installed but as mentioned in the doc there is no USB to serial interface on the arduino dock ! ).
    Last note : everybody talks about the power switch but there is no power switch on the Arduino dock 2 , only a reset button and it has no effect at all...

  • @Serge-insas
    Onion Omega2 Documentation
    Getting Started

    The firmware of your Omega2+ is very old.
    You should do a First Time Setup and a Firmware Upgrade.
    (If I were you, I would do this using SSH.)

    The latest well working firmware for Omega2+ (2017-03-26 20:30 CET)

    After a successful FW upgrade the amber LED will blinking, the OMEGA_RESET button will working and hopefully the Wifi client too.
    To get a serial terminal you should connect a 3.3V logic level serial to USB adapter (eg CP2102) to the OMEGA_TX, OMEGA_RX, GND pins.

  • @ccs-hello
    Excuse me for the previous OFF topic 😉
    BTW I was just about to write: what about the old firmwares and the new - and perhaps inexperienced - users.

  • @György-Farkas
    thx for your answer, SSH connect did work, my version is Version: 0.1.5 b130.
    Now the issue I have is that to make this connection I have to connect my wifi to the omega and not to my router.
    oupgrade tries to connect but of course it fails 😉
    I've dowloaded the .bin file, how can I tell omega to use this file instead of trying to get it on the web ?
    I can't actually find any explanation on this but I'm still not familiar with this community so I might be looking at the wrong place (please forgive )

  • @György-Farkas
    I succeeded in upgrading to version omega2p-v0.1.10-b160.bin using an USB stick, thanks for that. seems to be working now... I'll keep this post updated once I get further.

    many thanks

  • I think this topic should be a sticky.
    With the next batch kickstarter/indiegogo users coming I forsee a lot of can't connect/wifi/power topics, this can be a (help) topic for user facing power problems.

    When I received my Omega2+ I had the problem that after 20 seconds the led went out.
    I used the recommended lm1117, breadboard and wires as power supply.

    After some advice on this forum, i shortened the wires from 20cm to about 5 cm each and I added a 470uF 16v Capacitor.
    I finally saw the Wifi Acces point in windows so i:

    • Connected to Omega-xxxx (default password 12345678)
    • Went to and run the setup wizard.
    • After setup, i did a browser refresh and immediately updated the firmware in the settings panel.

Looks like your connection to Community was lost, please wait while we try to reconnect.