We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

[Resolved] Bricked Omega2: No IP address and no working serial

  • Hi,

    I'm using an Omega2 with a Power Dock, and I'm trying to connect via serial through an FTDI cable (6-pin, only using GND, TX, and RX) to their respective pins on the dock. Unfortunately, I don't seem to be getting any output when using screen or PuTTY.

    This started when I initially connected to the Omega2 via the WiFi access point and tried to get it to connect to my home WiFi, either by using the web setup or SSH. Neither worked, and so I desperately tried some command (can't remember what exactly) that gave me a default WiFi configuration. I piped the output of it to /etc/config/network, and now I only get an SSID called "WRTNode2P_XXXX" (where 'XXXX' are the 4 characters that make up the end of the MAC address). Additionally, neither using mDNS or any IP address seems to yield any results for connecting to the Omega2 via SSH.

    Unfortunately, as I stated, I only have a power dock, so I'm unable to connect via serial through an expansion dock or mini dock.


  • I think you have a few options.

    1. Have you gotten screen working with your Omega2 already? If not, I would start with your setup there.
      Be sure to use 115200 baud rate.
      Ensure your RXin of FTDI is going to TXout of Omega, and visa versa.
      Make sure you are using a 3.3v FTDI. If your FTDI has RX/TX LEDs on it then verify while you are in screen mode that pressing enter will flicker the TX LED on your FTDI.
      Loop your FTDI TX into your FTDI RX and ensure characters typed are echoed in your screen.
      The Expansion doc has series 1K resistors in the serial portion of the RX/TX lines between the CP2102 (USB to Serial adaptor) and the Omega.
      After you startup screen have you tried a power cycle of the Omega you should get kernal/boot data.

    2. If all else fails the power doc has the factory reset button, per docs

  • @Armeen-Mahdian
    You should try the Factory Restore and after that go back to the First Time Setup.
    Good luck!

  • @Jeff-Seese
    Thank you for the suggestions. I tried all of them, and unfortunately none of them seemed to have any effect. I did test the FTDI by looping TX into RX and typing into the console, which worked properly. I also tried the reset button, but it didn't seem to do anything, even after a manual power cycle afterwards. This happens to be an Omega2 that still has the firmware from when I first got it off Kickstarter, and I noticed that the reset button was fixed in some build in the docs.

  • @Armeen-Mahdian
    To get a Serial Console / Terminal for effective troubleshooting (and for easy debricking 😉

    • either solder wires to the relevant header pin pads RX0, TX0, GND of the Power Dock

    • or try what greenbreakfast / @Lazar-Demin suggests here - use your Power Dock and the relevant pins RX0, TX0 of course

    Put a wire into each of the pins shown below:
    When using stranded wire, you'll need to twist the ends to make it easier to plug in.
    With the wires in place, plug the Omega into the Mini Dock, ensuring that the wires are into the Mini Dock's headers by the Omega's pins. It will take more pressure than usual to plug the Omega in since the pins need to squish in with the wires, be careful to not break anything! Stranded wires work well since the strands have some mobility and can accomodate the pin.

    Although @Lazar-Demin is a highly educated engineer if I were you I would choose the soldering.

    Good luck!

  • @György-Farkas
    Thank you! I ended up taking the Omega2 out of the dock and connecting via serial to RX0 and TX0, and it seems to have done the trick.

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.