We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

LAMP Stack: Rights Management Issues

  • Hey,
    I expanded the storage of my omega with this instruction https://wiki.onion.io/Tutorials/Using-USB-Storage-as-Rootfs (pivot-overlay)
    Then I tried to setup a LAMP Stack.

    After installing and configuring Apache successfully (with help of this instruction: https://wiki.onion.io/Tutorials/How-To-Install-LAMP-Stack-on-the-Omega ) I noticed that I could not access the files I created in the htdocs folder with my browser. It always droped a 403 Forbidden error.
    I was able to solve this by changing the access rights of those files via chmod to 0777.

    Than I continued setting up my LAMP Stack with the php component. Unfortunately after doing this, I am not able to open php files with my browser. It always says
    **Forbidden You don't have permission to access /php/php-cgi/[filename].php on this server.
    It is interesting that it does not show the correct path (which would be /htdocs/[filename].php or just [filename].php) but the /php/php-cgi/ directory. Changing the access rights of the php files like before does not help anymore.

    Does anyone have an idea how to solve this?

  • I've no idea how and why - but after reinstalling the apache package again twice now it works...


  • @Peter-Harrald Hi Peter, sorry for the late response. I was still trying to duplicate the problem and then you mentioned it was fixed. My best guess is that one of the apache configuration files wasn't setup properly. Re-installing the package is like the software version of "turning it off and on again", lol.

Looks like your connection to Community was lost, please wait while we try to reconnect.