We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

OLED does not display

  • Hello,
    I got a new Omega2+ and the OLED has been unresponsive. I've tried a lot of things from these forums but still no luck. Any help will be much appreciated.

    This the the serial output when it boots :
    Board: Onion Omega2 APSoC DRAM: 128 MB
    relocate_code Pointer at: 87f60000
    flash manufacture id: c2, device id 20 19
    find flash: MX25L25635E
    *** Warning - bad CRC, using default environment

    Onion Omega2 UBoot Version:
    ASIC 7628_MP (Port5<->None)
    DRAM component: 1024 Mbits DDR, width 16
    DRAM bus: 16 bit
    Total memory: 128 MBytes
    Flash component: SPI Flash

    % oled-exp -v
    onion-i2c:: Reading 1 byte from device 0x3c: addr = 0x80 read 1 byte, value: 0xff

    But when I write using command line of using the graphical UI - the screen stays blank!


  • Hi Douglas,
    Yes I'm using the OLED expansion dock. Yes I did try all these but to no avail.
    Specifically ...

    :/# oled-exp -ic

    Initializing display
    Clearing display
    :/# oled-exp power on
    Setting display to ON
    :/# oled-exp -ic
    Initializing display
    Clearing display
    :/# oled-exp write "hello "
    Writing 'hello ' to display

    But nothing displays and no error message.
    Are there any debug commands that will tell me whats wrong?


  • have you tried using the OLED app? perhaps an outside chance that text color is same as background color? i
    am not aware of any debug commands.

  • Yes, I have tried the Oled app ( but no luck.
    I also tried the "oled-exp invert on" but none of the command display anything. Not sure how to change the cursor color.

    What is the way to debug this? Is there a way for me to check the power supply or something basic like that?

  • even if you want to keep trying to find a solution , i would put in a ticket to get a replacement. put a link to this thread so they can read what you have tried. i have not seen a diagram of which pins are used for the oled. i think it is an i2c device, not positive though. but you could use male/female jumper wire to get the oled out of the expansion header to test components on reverse side of screen. i see a few traces from the pins but not well enough to determine which pin they are from.

  • @Anupam-Bakshi
    This is a little strange. Can you please take some pictures of your OLED from the top and the bottom and post them here?

    The OLED is an I2C device, you can check the power by looking at the 3.3 Volt and Ground pins.

  • I've checked 5.0 and 3.3 V pins on the extension board and they have the specified voltage.

    Attached are the pictures ...

    0_1505657740976_IMG_20170903_222845081.jpg 0_1505657751419_IMG_20170903_222903422.jpg 0_1505657760611_IMG_20170903_223003733.jpg 1_1505657771200_IMG_20170903_223848661.jpg 0_1505657771200_IMG_20170903_223950272.jpg

  • Surely there must be some way to debug this. Any help will be much appreciated.

  • @Anupam-Bakshi said in OLED does not display:

    Surely there must be some way to debug this. Any help will be much appreciated.

    you have done everything i can think of possible and so i'd suggest contacting paypal or other payment used and explain that the device has never worked, you tried all ways to seek help and now almost 2 months later still not resolved. honestly, i'm surprised onion has not sent a new one, but i learn something new every day.

  • It's the cable and/or the usb power supply/port!, use a genuine 2.0a/2.4a usb cable(one that came with your phone) and plug the cable directly into a pc(not a hub!)usb 3.0 ports usually work better than 2.0 or a genuine cell phone charger rated at 2.0a/2.4a, low voltage, hubs etc can cause issues, I changed my cable and tried other ports and everything worked fine, I also thought mine was broke!

  • Onion sent me a new OLED, and I'm happy to report that it is working just fine. I didn't change anything else.
    If I get time, I'll try to debug whats wrong with the original one. Suggestions welcome.
    I did notice that when with the new OLED, when I do
    % oled-exp -v

    So the value changed from 0xff to 0x03. Not sure if that matters.

    Thanks to everyone who tried to help out. Appreciate that.

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.