We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

De-Brick help

  • So I bricked my Onion Omega trying to load a custom build.

    So it doesnt work and just kernel panics.

    I have an Ethernet expansion, no bother, but Im missing a full size dock as I ordered the battery dock which hasnt shipped yet.

    So Im going off the following which @Boken-Lin posted on another thread, so Im connecting from ethernet module to minidock using the "jam multicorecables inbetween onion and minidock" method. So patching Tx- to Tx-, Tx+ to Tx+, Rx- to Rx- and Rx+ to Rx+


    I dont get a light if I plug an ethernet straight-through cable into a switch or a PC. When I run the httpd command in uboot I just get the error that states no cable is connected, I also get a cable not connected icon on my PC.

    Here are a couple of photos of my connection:
    Ive check all the connections are they are good, no short circuits anywhere^^^^

    No short circuits here^^^^

    These look like the correct pins compared to the diagram above^^^

    One thing that shouts out is the ethernet expansion seems to be a short cicuit between all 4 pins. So if i do a resistance test with my digi-meter I get 0 ohms between all 4 pins? Does this sound correct? The pins on my omega dont seem to match this and it sounds like a posible fault with the ethernet module?

    Any help appreciated šŸ‘

  • Some more questions to do with the guide:

    • 1: Do you need a crossover to a PC? I'm sure a stright-through to a switch on the same VLAN should be fine.
    • 2: Im assuming you need to put the PC on the same subnet as the httpd process, its not really mentioned. So PC on 192.168.1.X/24 network

    Once these are answered, or I can answer them by de-bricking my omega Ill open a ticket for the guide to get updated.

  • @Sawyer-McBride in uboot, you can use setenv to use an ip address which is within your (private) subnet. You can also check in uboot with ping that another computer in your subnet is reachable.

  • @Johannes-Zellner thanks for the headsup.

    So I found off an Aruba site some setenv commands:

    setenv ipaddr
    setenv subnetmask
    setenv gatewayip
    setenv serverip
    setenv master

    save and reset dont work and im not sure what serverip and master are for, assume one is for setting TFTP source for an AP. Anyway the rest is very useful!

    However, not that usful until the httpd process recognises a cable is plugged in šŸ˜„

  • @Sawyer-McBride what happens if you ping from uboot to any other computer in your subnet?

  • @Johannes-Zellner Doesnt like it as the interface isn't up

    Omega> ping
    Link down: eth0
    Link down: eth1
    ## Error: ping failed, host is not alive!

  • @Sawyer-McBride You will need to disable the wifi on your computer for this to work. Most routers use subnet, which conflicts with the subnet for httpd service on uboot. Can you try again after disabling the wifi? Let me know how it goes.

  • @Boken-Lin I'm a network engineer and so in typical fashion have a different subnet. However the PC that I'm hooking up is my gaming rig and doesnt have WiFi or any other network connection to speak of (BlueTooth, USB Dock,).

    The problem I think is still Layer 1, ie the cable/connections from omega to network inf as no lights come up on the switch (i've tried 2 seperate switches and multiple known working ethernet cables) and if connected directly to a PC it doesnt recognise a cable plugged in. This part needs to be resolved before looking at addressing issues.

    That's what pointed me towards the ethernet-expansion as when I was doing continuity and resistance tests on the pins they all seem to be shorted together, does this sound correct?

  • @Sawyer-McBride Ah, i see. After taking a look at the pictures you took, you also need to connect the Net Power (2.0V) and Ground. Also, TX+ needs to be twisted with TX-, and RX+ with RX- (they are twisted pairs). You twist them together like the following picture:

    Twisted Pairs

  • @Boken-Lin Excellent stuff, thought that it might need some power somewhere along the way!

    Any idea what pins on the ethernet module?

  • @Boken-Lin No need dude šŸ˜‰

    So I used the following image, I thought I already knew this, or had seen it somewhere!

    Just hooked up the 2Vout and GND pins to the pins on the module and sorted, ethernet port came up on the switch, changed my IP on my PC (as was easier) and uploaded the image!

    Final wiring looked like the following:

    PS. Hope you like my twisted pairs šŸ˜‰
    Time to upgrade!!!

  • Following is the correct pins for anyone hitting a similar problem:

  • @Sawyer-McBride Nice! That picture looks like a surgical table for the Omega. I'm glad it pulled through and made a full recovery šŸ™‚

  • @Boken-Lin Haha, it pretty much was! The patient is doing well! šŸ˜

Looks like your connection to Community was lost, please wait while we try to reconnect.