We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

[Closed] Onion completely useless/broken to several issues

  • So, got my Onion today and want to power it up to try it, but after about 5h of trying, it turns out to be broken to several issues:

    First of all, I power the onion from a 10A Lab-bench Powersupply, wich should give enough current (I read a lot of that issue)
    I connected via Putty to the UART0 to watch the output.

    Well, I followed the instructions and updated the Firmware over USB with the "omega2-v0.1.10-b160.bin" wich i found here: http://repo.onion.io/omega2/images/

    Wich worked quite well...

    But: keeps rebooting on turning on the WiFi, even on adding 220uF + 100nF capacitance (Elko+ MKP) onto the piece of prototyping PCB I build for mounting the Onion.
    I can't get it to work up to the point I added a 560uF low ESR dry electrolyte capacitor on top of the actual ONION-PCB (directly beside the metall-casing, like WTF this looks like a design error to me?!) AND turning the voltage up to 3.37V wich MAY start up (or sometimes it crashes randomly, maybe it don't like me? Don't know...)

    Well, after several attempts I managed to get into the ONION-Wifi and tried to log onto my wifi, wich:
    Yep the Onion simply don't find it, nor connect to it if I type it in manually (and lots of random crashes again...)
    (But it finds the neighbors WiFi, wich is like 20m away, instead of my router beeing 1m on the other side of the table, like WTF?!)
    Yes, you could say its because I don't have a antenna connected, but with a 2-antenna Router a meter away from it, it should be good enough...

    I tried to setup it manually via the console, but that wasn't a success to, random crashes...

    So I'm sitting here wich a useless board wich I paid already 15€ for (because in Germany you can't get it any cheaper) and I have literally no clue how to work with the Onion...

    The fact that I can't really do anything with it beside looking at the terminal when rebooting and wasting about 5hours really annoys me (wich I guess you can quite read...)

    I'll attach a picture of my Onion2 too...


    And a log of the bootup:

    Any Help would be appreciated, or if no one knows anything I'll pack it up and send it back...


  • Does your 10A Lab-bench Powersupply show current reading?
    Please report back the values (from t=0 up to 25 seconds into boot.)


  • Hey,

    It draws about 150-200mA all the time and it seems to stay more or less constant.
    I can't give you more details right now, cause im not on my Workplace anymore...


    Edit: Nvm I sent it back...

  • I have similar problems, and my solution will be the same as yours, to return it to the reseller.

    Stay away from this scam...

  • You really need a 3.3V regulator near the power pins, the inductance of wires from the bench supply tend to make the system unstable.

    The Omega 2 is designed to be used as a mezzanine module on a circuit card with good power regulation. It's not so forgiving as a stand alone module.

Looks like your connection to Community was lost, please wait while we try to reconnect.