We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Omega 2+ not starting after package updates

  • Hi. I hadn't used my Omega 2+ in a while, so ran opkg update yesterday and saw that there were a load of packages that need upgrading. There doesn't seem to be a way to upgrade everything, so I started upgrading a few of them individually. After I did opkg upgrade opkg opkg seemed to stop working.

    I did a reboot to see if that would help, but the Omega won't start up properly now. The orange light comes on for about 8 seconds, then flashes for 3 or 4 seconds, then the light goes out. The WiFi access point never becomes available, so I can't connect to it.

    I've tried to do a factory reset several times, but holding down the reset button, but nothing seems to happen.

    Has anyone got any ideas? Thanks.

  • @Jonathan-Jefferies
    If you have a mini dock or expansion dock, try and connect to the console and see if you can get any hints as to what is happening in the boot stage.

    From your description of the start up, it fits the profile of not getting enough A's to start up, so if you're not powering the device from a dock, make sure it's getting enough 'juice' to boot. If you are using a dock, check the amperage of your power supply, often you need more than 500mA.

    I realise that doesn't correlate to the opkg upgrade, but in order to investigate that, the device has to start up at least.

  • Hey. Thanks. I managed to connect via serial. This is the last page of output:

    [    4.263776] phy phy-10120000.usbphy.0: UTMI 16bit 30MHz
    [    4.269118] ehci-platform 101c0000.ehci: EHCI Host Controller
    [    4.274983] ehci-platform 101c0000.ehci: new USB bus registered, assigned bus number 1
    [    4.283164] ehci-platform 101c0000.ehci: irq 26, io mem 0x101c0000
    [    4.308675] ehci-platform 101c0000.ehci: USB 2.0 started, EHCI 1.00
    [    4.316167] hub 1-0:1.0: USB hub found
    [    4.320409] hub 1-0:1.0: 1 port detected
    [    4.329459] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
    [    4.337382] ohci-platform: OHCI generic platform driver
    [    4.343043] ohci-platform 101c1000.ohci: Generic Platform OHCI controller
    [    4.350017] ohci-platform 101c1000.ohci: new USB bus registered, assigned bus number 2
    [    4.358133] ohci-platform 101c1000.ohci: irq 26, io mem 0x101c1000
    [    4.423797] hub 2-0:1.0: USB hub found
    [    4.428044] hub 2-0:1.0: 1 port detected
    [    4.445410] MTK MSDC device init.
    [    4.488808] mtk-sd: MediaTek MT6575 MSDC Driver
    [    4.496803] sdhci: Secure Digital Host Controller Interface driver
    [    4.503152] sdhci: Copyright(c) Pierre Ossman
    [    4.509064] sdhci-pltfm: SDHCI platform and OF driver helper
    [    4.519467] usbcore: registered new interface driver usb-storage
    [    4.529148] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
    [    4.546978] init: - preinit -
    [    5.389621] rt3050-esw 10110000.esw: link changed 0x00
    Press the [f] key and hit [enter] to enter failsafe mode
    Press the [1], [2], [3] or [4] key and hit [enter] to select the debug[    5.589270] random: procd: uninitialized urandom read (4 bytes read, 10 bits of entropy available)
    [    8.436149] jffs2: notice: (396) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found.
    [    8.455942] mount_root: switching to jffs2 overlay
    [    8.493035] urandom-seed: Seeding with /etc/urandom.seed
    Error relocating /lib/libubus.so: uloop_cancelling: symbol not found
    [    8.617476] watchdog watchdog0: watchdog did not stop!
    [    8.622934] Kernel panic - not syncing: Attempted to kill init! exitcode=0x00007f00
    [    8.622934] 
    [    8.633759] Rebooting in 1 seconds..

    I remember seeing the Error relocating /lib/libubus.so: uloop_cancelling: symbol not found or something similar while I was doing some opkg upgrade ..., so presumably it's related to that.

  • OK. I've pressed F + Enter to enter Failsafe mode and it's given me the option to do a factory reset...

  • I've done the factory reset, and now the access point comes up and I can connect to it. When I try to run wifisetup I keep getting the same Error relocating /lib/libubus.so: uloop_cancelling: symbol not found over and over again.

    Potentially the same issue as in this post: https://community.onion.io/post/15469

  • @Jonathan-Jefferies
    Possibly. If you can identify the correct libubus package, you could try downloading it from the repo (there are a few revisions there) and then installing it manually.
    But honestly, since you don't seem to mind resetting your device, I'd suggest you just reflash it from USB using the stable b160 firmware image and start from scratch.

    Quite why a factory reset doesn't do what it says on the tin is a bit disconcerting though. What's so special about libubus that when it breaks, it survives a factory reset? More research required.

  • I assumed a factory reset was my only option. Hopefully all the code I had on there is in repositories anyway, so I'm hoping it won't matter too much.

    It does seem very strange that the problem with that package still exists after the factory reset. I'll try and get some more information.

  • Ok, I must've not done the reset correctly. It's worked now.


    Thanks for your help šŸ™‚

Looks like your connection to Community was lost, please wait while we try to reconnect.