We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

WiFi AP fails after firstboot -y

  • OK guys, see my last post for why I decided to reset to factory defaults (hint: firmware upgrade caused "onioneer" not to work as the login password). Having reset to factory default via:
    firstboot -y
    I am not left with an Omega2 that is no longer broadcasting a WiFi AP. Nothing, nada, zip, zilch. I have no WiFi named Omega-XXXX, so now I can't even restore via SSH. This isn't cute guys. Why in the hell can I not download the firmware onto my Macbook and install it via USB? Hmm? Or something? Is it really practical to expect everyone to want/be able to update/upgrade firmware via a wireless connection.

  • @William-Srite said in WiFi AP fails after firstboot -y:

    Why in the hell can I not download the firmware onto my Macbook and install it via USB?

    Restoring the firmware (unbricking the device) is possible when you put the firmware file on a USB stick and plug it into the Omega2, provided you have a dock which exposes a USB port.

    See https://docs.onion.io/omega2-docs/Firmware-Flashing-from-USB-storage.html, this saved me multiple times.

    Also if you have a Mini or Breadboard dock you can connect to the Omega via the serial connection and check out what's wrong. (e.g. executing wifisetup to connect to your network again)

  • Tried that. It fails when I tried to run the USB to serial connection. Downloaded the driver, tried to open a connection. Failed before I got to a screen.

  • Tried that. It failed before it opens a screen. Downloaded the driver, followed instructions and couldn’t get past the screen /dev/tty.SLAB_USBtoUART 115200 command.

Looks like your connection to Community was lost, please wait while we try to reconnect.