We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Unable to install grpcio(gRPC) on onion omega 2+

  • I have been trying to install grpcio on omega 2+ but this error pops up every time I try. I tried using both pip and pip3, tried with and without virtualenv.


    Any help is appreciated. Thanks in advance.

  • Hey @Sushanth-Varada --

    The grpcio wheel includes a shared object library. There are downloads for AMD and ARM architectures but not MIPS (as used by the Omega).

    Someone could provide a build for the Omega but this hasn't been done perhaps because it may hit the device's resource constraints.

    An alternative -- if you're not bound to Python -- is to use one of the other languages (for which there are protobuf generators) that supports cross-compilation (and static binaries) including Golang and Rust. With Golang, you may develop on one platform and then cross-compile the code to run it on an Omega:

    GOOS=linux GOARCH=mipsle go build -o your-binary /path/to/main.go

    I used the Golang helloworld sample and the client produces a ~12MB binary that runs on the Omega.

Looks like your connection to Community was lost, please wait while we try to reconnect.