We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Cross Compiling

  • I've followed the docs to set up my environment on Ubuntu 17.10, I can create a basic app so long as I do not refer to the Onion specific functions.

    I installed the header files and the lib*.so, however my build continues to fail. I'm attaching an example of my error here, can anyone see what I am missing please? I'm very rusty on my C so I might just be missing something obvious. Thank you !


  • Did you recompile the .so from source or did you copy the from your Omega2? Because the latter never worked for me. (see https://github.com/gamer-cndg/omega2-libs)

  • I copied them from the Omega2, I couldn't find he source anywhere, where is it?


  • There seems to be a problem in the documentation as it states:

    "If you’re using our omega2-source Docker image or building based on our source GitHub repo, you’re all good as it’s selected for compilation by default."

    The source repo doesn't contain the source files for the libraries so they don't get built. It looks like Omega wants us to use Docker as the docs continually refer to docker as does the examples. Docker cannot coexist on windows with VMWare so it's not an option for me. I've wasted hours trying to get this to work and still no luck.

  • You can run docker inside the Linux Guest on VMWare, its what I've been doing.

  • Daniel that is an interesting idea, but I expect it will quite slow given the overhead.

    I'm currently building the the LEDE system on the docker image running on my Surface 4, i7, 16GB, Windows 10 Pro 64Bit the build has been running for about 18 hours and still has not completed. The same build on the same machine but running Ubuntu 17 on VMWare Workstation Pro 15, builds in about 2 hours.

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.