We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Onion Omega Pro broken?

  • I just got my onion omega pro delivered last week. I had no problems getting it set up on my home's wifi connection, and am able to connect to it via SSH. However, I have been unabled to install any of the apps through the web interface. When I try to install the "Timelapse Camera" app, for example, .. the green install button changes to a loading indicator, but nothing ever gets installed (I've waited as long as 20 minutes .. and even tried re-booting the device). And when I open up my browser's javascript console, I see the following JavaScript Errors:

    Unhandled promise rejection
    Object { code: -32000, message: "Object not found" }
    Unhandled promise rejection
    Object { code: -32000, message: "Object not found" }

    Also .... whenever I try to run "oupgrade" via the command line when I'm logged in through SSH, .. I get the following error message, and the upgrade doesn't happen.

    local: line 378: not in a function

    And yes .. I've already tried doing a factory reset by holding down the reset button for 10+ seconds. There was absolutely no difference after I went through the setup again.

    So what the hell happened? Has anyone else here encountered this same problem? What should I do? Should I try to return it or something? Or is this fixable?

    -- Yvan

  • @emma-humphries posted about this same issue here and provided the solution she found as well. Her solution worked for me. Thank you @emma-humphries!

Looks like your connection to Community was lost, please wait while we try to reconnect.