We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Error when setting up Omega2 Pro [with solution]

  • I received my Omega2 Pro today and started setting it up this evening.

    During the initial setup, the web interface 'hung' during the firmware upgrade. I reloaded the browser and was able to login to the console.

    Running oupgrade -c, I found I needed to upgrade still.

    When I ran oupgrade, I got the error message:

    /usr/bin/oupgrade: local: line 378: not in a function

    I went looking in the Onion GitHub repos and found this patch at https://github.com/OnionIoT/oupgrade/commit/941a638283e2acfefe5fdab33886cdd672d949a8

    I made the one line change to the script and was able to run oupgrade.

    You'll also need to run the onion os update command to get the new apps once you've upgraded the firmware.

    I guess some of the boards didn't get the latest patches before they were shipped?


    Emma H.

  • I had the same problem, and can confirm that Emma's solution solved it for me.

    Thanks, Emma!

  • Pardon my ignorance, but where exactly is this file located on the Onion (ie: oupgrade.sh)?

    -- Yvan

  • @Yvan-Gagnon
    It's not oupgrade.sh, just oupgrade and it's in located in /usr/bin:

    root@Omega-FA93:~# which oupgrade

  • administrators

    To chime in: yes, there was a bug in the oupgrade program in the firmware that was installed during production. This has since been fixed and the fix is included in the latest firmware.

    So there's three ways you can upgrade your Omega2 Pro if you are on firmware v0.3.0 b207 or lower

    1. Use the browser-based setup wizard, the steps can be found here
    2. Follow our manual firmware installation guide, just note for step 1, you can find the latest Omega2 Pro firmware here
    3. Make the fix to oupgrade as mentioned above

    Once you've installed the latest firmware, oupgrade will work as intended šŸ™‚

  • I too can confirm that applying the patch works and allows me to upgrade the device. However .. I'm having some issues with the browser based interface -- with the App Manager in particular. I was only able to install the Timelapse Aamera & Power Dock 2 Apps. Attempts to install any other apps Continually fail.

    How would I install the apps via the command line?

    1. Legacy Console
    2. Node-Red
    3. Code Editor

    -- Yvan

  • I got my Omega2pro on Friday and had the same problem but not checking here first (not been here for a long while) I emailed Lazar who gave me some pointers and I ended up downloading the b211 BIN file from the repository and after copying the BIN file to /tmp used the manual update with file method. I noticed versions b212 and b213 were on the repository but "oupgrade check" was happy that b211 was the latest?

    I did hit a massive snag - I was using Firefox on an iMac "connected" to the Onion at and using the busybox terminal program on the Onion itself. Problem was I couldn't type the dash symbol (between the zero and equals keys) - the key worked everywhere else except in busybox. Tried a wired keyboard on the iMac and the dash key still didn't work. Curiously the minus key on the number cluster of my wired keyboard did work allowing me to type the BIN file's name properly.

    Anyone else found something as daft as that?

  • based on what i've read before in other threads the firmware for the omega2 pro can be flashed to the omega2+, is this correct? i also wanted to mention that the links for "images" and "packages" appear to be broken on this page

    the link address for "images" is [on chrome]

    and for "packages" is [on chrome]

  • I have to say .. it turned out that I was mistaken about the patch being the solution (for me, anyways). Although it did allow me to run oupgrade and get everything seemingly up to date .. minutes after I posted my reply, my device started behaving erratically, continuously disconnecting from and reconnecting to Wifi, and was mysteriously re-booting itself about every minute or so. I ended up having to do another factory reset and took another shot at re-configuring my Wifi connection and installing apps through the browser interface (which I succeeded at, .. finally). There was no rhyme or reason to it, to be honest.

    I think the main problem is that there's never any clear indication that firmware updates, Onion OS updates, or Apps have been properly downloaded or installed, or if/when rebooting the device is necessary. Now that I've finally got the device up and running, I'm reluctant to ever apply any other firmware or Onion OS updates ever again, because it always results in problems. I encountered the exact same issues with my Omega2+.

    -- Yvan

  • thanks, that did also the trick at my omea, I suggest to also mention the fact that after the upgrade you lose your ssh connection, if used, and have to wait a minute. cheers Ger

  • I had the same issue with oupgrade, the patch didn't work for me. Instead I just commented out the lines:

    #local verbosity="-q"


    if [ $bJsonOutput == 0 ]; then



    then removed the reference to $verbosity in the wget command below.

  • administrators

    Made an official, pinned thread on this:

    Note that since oupgrade has been fixed, you can install the latest version and then use it to upgrade your firmware:

    opkg update
    opgk upgrade oupgrade

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.