SSH Connection Refused



  • I have two Omega2+ that I can no longer connect to. I can get into the console but I can't SSH to the device, I get "connection refused". I have tried to connect via Putty and MobaXterm...I deleted the .ssh/hostkey for 192.168.3.1 for MobaXterm but this didn't solve the problem. I have tried reinstalling the firmware via the reset button on the Power Dock 2, this has worked because the Omega's no longer connect to my wifi network but this doesn't solve the SSH issue.

    I have an Omega2 as well, I can connect to that device via SSH without issue.



  • if you can get into console does that mean you can access the terminal app? if you can access terminal i guess you can determine if the ssh service is running? or even installed. maybe from console you can do a check for newer firmware. i'm thinking it's possible the ssh service was set to not start or is not installed. or maybe someone or thing set a firewall setting somewhere that blocks ssh.



  • Thanks for the response Douglas! I didn't state the current status correctly in my original post. I was able to access the terminal app in console when I first started getting the "connection refused" error but since I reset the devices I cannot access the console now. My network doesn't show up in the list during setup so I can't get passed that screen. I tried to connect one Omega to another and was able to get to the "Software" step but because the other doesn't have internet access the device just got hung up trying to load this step.

    I was using both devices up until I tried installing NodeJS on the one that didn't have a SD card, the device ran out of memory and everything seemed messed up from that point. I tried putting an SD card and it seemed like my SSH connection was refused after that. I transferred the SD card to the other Omega and then it was connection refused there as well. I have removed the SD card from both at this point and tried a factory reset but still connection refused.

    I found this topic where other people were having the same issue: https://github.com/OnionIoT/Onion-Console/issues/64 There is something mentioned about cookies but I think that is only related to accessing the console via omega-XXXX.local...I access via IP so I don't care about this and don't see how a browser cookie could stop SSH in other programs.



  • well, if you have the expansion dock or mini dock i'd suggest doing the usb recovery routine.
    https://docs.onion.io/omega2-docs/Firmware-Flashing-from-USB-storage.html
    there is really no telling what condition, except non-functional, your omega2 is in and since a reset did not fix it i personally would not spend any additional time trying to figure out what the current state is and how to fix it. i'd start over by doing the usb recovery with the latest firmware.
    if you don't have either dock or some diy garage method of hooking a usb serial host to the pins then i'm out of ideas.



  • thanks for pointing out, i just ordered the expansion dock...I was using the power dock. I'll report back if this fixes it...hopefully my troubles can at least benefit someone else


Log in to reply
 

Looks like your connection to Community was lost, please wait while we try to reconnect.