We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

How to install node-red on Onion Omega2+

  • Hello there,

    I'm trying to install node-red on my brand new omega2+, but i don't find how.
    I've read the tutorials and it should be easy enough to install node-red, but it just won't install.
    What i've tried:

    1. Installing by OnionOs App manager
      => I don't see node-red there !?!?!
    1. Installing by command promt
      => I get this:
      root@Omega-34AF:~# opkg install oos-app-nodered
      Unknown package 'oos-app-nodered'.
      Collected errors:
    • opkg_install_cmd: Cannot install package oos-app-nodered.

    Can somebody help me out please?

    PS I did an update of the rpositories ­čśë

  • @Koen-Schockaert You have an Omega2+. What firmware version are you using?

    Please take a look at the official Onion Omega2 Documentation
    Installing and Using NodeJS
    Node-Red on the Omega2 Pro

    Useful commands:
    opkg update
    opkg list | grep -i node
    opkg install node

    # Omega2+ FW v0.3.2 b227
    root@Omega-5BE1:~# opkg update
    root@Omega-5BE1:~# opkg list | grep -i node
    node - v8.10.0-3 - Node.js® is a JavaScript runtime built on Chrome's V8 JavaScript engine. Node.js uses an event-driven, non-blocking I/O model that makes it lightweight and efficient. Node.js' package ecosystem, npm, is the largest ecosystem of open source libraries in the world.
    node-npm - v8.10.0-3 - NPM is the package manager for NodeJS
    onion-node-red - 0.19.5-1 - Flow-based development tool for visual programming
    oos-app-nodered - 1.0.0-1 - Node-Red : Node-Red Graphical Programming interface [Omega2 Pro]
    root@Omega-5BE1:~# opkg install node
    Installing node (v8.10.0-3) to root...
    Downloading http://repo.onioniot.com/omega2/packages/packages/node_v8.10.0-3_mipsel_24kc.ipk
    Configuring node.

  • @Gy├Ârgy-Farkas Thanks for helping me out!
    I'm really lost here, i'm sure you figured out that i am a total newbie with the onion, have lots of expierence with rapberry and arduino. Then i found out about this amazing piece of hardware and want to give it a try.

    I'm up to date with the firmware:

    root@Omega-34AF:~# oupgrade -check
    > Device Firmware Version: 0.2.2 b201
    > Checking latest version online...
    url: https://api.onioniot.com/firmware/omega2p/stable
    > Repo Firmware Version: 0.2.2 b200
    > Comparing version numbers
    > Device firmware is up to date!

    I'm getting the message that firmware is up to date, but i can see that you have a newer version?

    root@Omega-34AF:~# opkg list | grep -i node
    blynk-library - 0.4.5-1 - Blynk library package built for mips.Updated:No Node Dependencies
    node-oled-exp - 0.2-2 - Node module for OLED Expansion
    node-pwm-exp - 0.2-2 - Node module for Servo (PWM) Expansion
    node-red-contrib-ibm-watson-iot - 0.2.8-1 - node-red-contrib-ibm-watson-iot package built for MIPS
    node-red-install-tool - 0.1-1 - Script for installing node-red on automounted usb storage for Omega2
    node-relay-exp - 0.2-2 - Node module for Relay Expansion
    node-usb - 0.1-1 - The node-usb package cross compiled for openwrt
    nodejs - v4.3.1-1 - Event-driven I/O server-side JavaScript environment based on V8
    npm - v4.3.1-1 - Node.js Package Manager
    onion-console-node-red - 0.1.4-2 - Node red app fo the console
    onion-node-red - 0.1-1 - Node-Red built for mips Ar971XX.
    onoff-node - 0.1-1 - Onoff package built for mips.

    I expected to see
    oos-app-nodered - 1.0.0-1 - Node-Red : Node-Red Graphical Programming interface [Omega2 Pro]
    but it isn't there!?

    Thanks again for helping me out ­čÖé

  • I'm even more confused now.
    I did this:
    firstboot -y
    To get back to factory settings. That went fine.
    So when i have:

    root@Omega-34AF:~# opkg list | grep -i node
    node-red-install-tool - 0.1-1

    So i tried running the install tool:

    root@Omega-34AF:~# node-red-install-tool
    STARTING 10 second delay

    And thats all ­čś×

  • @Koen-Schockaert You could update the latest firmware on CLI with oupgrade -l -f (ie. with oupgrade --latest --force).

    Yes, firstboot -y; reboot is one of the 'Factory Restore' methods.
    After a 'Factory Restore' you have to repeat one of the 'Initial Setup' procedures - after that run opkg update and hopefully you'll be able to install what you want.

  • Thanks angain for your advice, @Gy├Ârgy-Farkas
    But i have no luck with node-red on my system.
    I managed to install node-red:

    root@Omega-34AF:~# opkg install oos-app-nodered
    Installing oos-app-nodered (1.0.0-1) to root...
    Downloading http://repo.onioniot.com/omega2/packages/onion/oos-app-nodered_1.0.0-1_mipsel_24kc.ipk
    Installing node (v8.10.0-3) to root...
    Downloading http://repo.onioniot.com/omega2/packages/packages/node_v8.10.0-3_mipsel_24kc.ipk
    Installing onion-node-red (0.19.5-1) to root...
    Downloading http://repo.onioniot.com/omega2/packages/onion/onion-node-red_0.19.5-1_mipsel_24kc.ipk
    Configuring node.
    Configuring onion-node-red.
    Configuring oos-app-nodered.

    I was so happy ­čÖé
    But it didn't last long. Seems node-red is not compatible with the Omega2+ !?!?!?

    I don't understand why i am able to install it then.

  • UPDATE, first time i opened node-red interface, i got an error.
    Second time i opened node-red, it was working!
    Node-Red seems to work on the omega2+ after all ­čÖé

  • @Koen-Schockaert Maybe Onion guys optimized (or made) the Node-Red package only for Omega2 Pro - I don't know exactly.

    Unfortunately I don't have any genuine Onion Omega2 Pro,
    I don't use the web based UI (Onion OS or OnionOS - whatever the 'OS' means here ­čśë
    and I haven't tried the Node-Red package (the Node-Red Graphical Programming interface) yet.

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.