USB device yoctopuce



  • I am trying to use a yoctopuce board (altitude to start with) on the USB A port of the dock board with an Omega2+.
    And using python. It complains that libusb-1.0.so.0 is absent. At this point I have resorted to using a pi instead.
    Is Omega supposed to be able to work the yoctopuce devices?
    root@Omega-8F12:~# python tryYoctoAltitude.py
    Traceback (most recent call last):
    File "tryYoctoAltitude.py", line 46, in <module>
    initYocto()
    File "tryYoctoAltitude.py", line 27, in initYocto
    show(YAPI.GetAPIVersion() +'\r\n')
    File "/root/yocto_api.py", line 2031, in GetAPIVersion
    YAPI.yloadYapiCDLL()
    File "/root/yocto_api.py", line 930, in yloadYapiCDLL
    "): " + str(ex))
    ImportError: Unable to import YAPI shared library (/root/cdll/libyapi-mipsel.so): Error loading shared library libusb-1.0.so.0: No such file or directory (needed by /root/cdll/libyapi-mipsel.so)
    root@Omega-8F12:~#



  • @Michael-Mayo

    Does the file /root/cdll/libyapi-mipsel.so actually exists? If it does exist check your symlinks, libusb-1.0.so.0 may not exist.

    You can troubleshoot loading the so by using insmod to report any missing dependencies.



  • @crispyoz said in USB device yoctopuce:

    libusb-1.0.so.0 may not exist

    /root/cdll/libyapi-mipsel.so is present.
    libusb-1.0.so.0 does not exist.
    I don't know how to obtain a libusb-1.0.so.0 for omega+.
    I have still given up trying to fix this.
    Somebody else, though, might want to use yoctopuce with onion.



  • @Michael-Mayo

    libusb-1.0.so.0 is a symlink to the so, you can just create it :

    cd /lib
    ln -s libusb-1.0.so libusb-1.0.so.0


Log in to reply
 

Looks like your connection to Community was lost, please wait while we try to reconnect.