We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Little bit confused with the hardware and getting started

  • Hi, I just received the onion few days ago, and I still confused with the h/w quality and the getting started page.

    I received the onion omega with one pin is already bent from the beginning
    (this is the photo that I've taken before I used it)


    Since this is probably an easy problem (only need to make it straight, I'll just skip this part)

    but the second is....

    Till today, I still can't connect to the h/w, either I'm wrong or... there's something wrong with the h/w

    I already connected to the wifi (ONION-ABCD) and can browse into the ONION-ABCD.local (which is stated @ getting started), but the Wizard is only shown like this
    (Power on with Onion Omega connected to Mini-Dock with microUSB-USB connected to PC)

    Screen Shot 2015-11-05 at 10.28.23 AM.png

    (Tested using the Safari, Firefox v41.0.2, 42.0 on OSX El Capitan 10.11.1, and from Android Web Browser, all same result, wizard not asking for login)

    so... idk how to connect to this omega, is this my fault / stupidity or h/w fault?

    Thanks.... i need the direction to use this omega @.@

    I tried to use the screen from OSX Terminal after installing the driver
    This one
    Silicon Labs CP2102 driver from https://www.silabs.com/Support Documents/Software/Mac_OSX_VCP_Driver.zip.

    and after write the
    screen /dev/tty./dev/tty.SLAB_USBtoUART 115200

    it only shows blank page
    Screen Shot 2015-11-05 at 10.34.26 AM.png

    So.... I can't connect to the device at all...

    Need "enlightment" in order to use this device...

  • Regarding the failure to show proper screen when accessing from Firefox and Safari, this is a known problem with javascript code on the Omega that is being worked on by the Omega Elves šŸ™‚
    See the following for more information:

  • okay.... thanks fyi
    @Boken-Lin already state it on the previous post too šŸ™‚

    Now I can get through the wizard ... and now the second problem ...
    Firefox still can't get through the onion console...

    Screen Shot 2015-11-05 at 1.56.48 PM.png

    and this is the error given by the Web Console
    Screen Shot 2015-11-05 at 1.55.30 PM.png

    Note that the "gobj is undefined" err appeared after I open/close the arrow at the right side of the Onion-XXXX

    Thanks, I'll be waiting for the update in order to work with safari / firefox šŸ™‚
    Since working with Ms.Edge is a lil bit pain for me šŸ™‚

    FYI: the "screen" command still left me a blank screen in osx terminal...
    is this considered a bug or normal?

  • Ok. Seems like we have identified the bug. I will fix it for the next release šŸ™‚

Looks like your connection to Community was lost, please wait while we try to reconnect.