We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Can't get wifi working.

  • Is there a way of flashing a different firmware over the AP interface?

  • @James-Spaloss If I were you I'd simply

    • restart the host PC
    • perform a Factory Reset / Restore on Omega2+
    • repeat the Initial Setup
    • and try to connect with wifisetup '1) Scan for Wifi networks' to the host PC's AP to 'SpalossGuest' (???).

    The outputs of cat /etc/config/wireless, ifconfig, logread | tail -n 50 are useful info.

  • @James-Spaloss
    I wrote "and try to connect with wifisetup ... to the host PC's AP to 'SpalossGuest' (???)".
    Most probably I was wrong because 'SpalossGuest' is not a WiFi AP on your host PC.

    What is 'SpalossGuest'? Is it your Internet gateway, a WiFi router, a standalone WiFi AP or ...?

  • Thanks for the help.

    I'm on my 3rd, factory reset.

    SpalossGuest is an SSID on on my home wifi setup. There are 2 Unifi AC Pro APs serving the wifi.

    I also tried using my phone as a Wifi hotspot with the same results.

    iwconfig shows that I am associated, but ifconfig shows no traffic sent or received. If I am really associated, shouldn't there at least be some outboud traffic for the DHCP requests? I'll post configs.

  • @James-Spaloss Unfortunately Omega2's ifconfig doesn't show the WiFi network traffic - RX bytes and TX bytes of apcli0 and ra0 are always 0 (0.0 B). 😞

    Search our forum (keyword: Ubiquiti) - some Omega2 users have similar issues with these devices.
    Sorry, I don't have any Ubiquiti device so I can't help to solve these problems.

  • Thanks.
    I will.

  • Ok. After some hunting and trying, I'm still not able to connect to the Unifi, bit I can connect to my phone's hotspot with no security. Not ideal, bimut I can start working on other things.

    Ultimately, the device will need to work from the phone's hotspot as a proof of concept, so for now, it's good enough.
    I have access to crappy old routers, so that should hold me over until what seems like a firmware bug gets resolved, or. I figure out how to get an older firmware flashed. (others are reporting that older firmware works)


  • @James-Spaloss I use unifi in several locations including my apartment where i have 20+ Omega2+ and 2S+, I have had some issues previous but these are easily resolved by upgrading the firmware. What version of the unifi firmware are you using on your AP?

    Other things you can do to help resolve the issue are in the Unifi controller UI. In settings under the services section disable "Enable Advanced Feature" also disable connectivity monitor. You may need to restart the AP in order for these to have effect, Ubiquiti tells me this is not required but my experience differs.

    Next you can enable Remote Logging, the devices will publish a lot of useful information including diagnostics/debugging logging which provides quite detailed information about clients attempting to connect to the AP(s) and the handshaking etc tat is taking place. I expect your answer is in this log.

  • Thanks, I'll give it a try.
    Sorry about the lag. I'm juggling several projects this weekend.

  • Ive read through about 2 years worth of posts with people not being able to connect to wifi.
    THe main problem i find is that the kernel is only good for USA. I use channel 14 for my wifi as most routers only use up to 11 as default so i have pretty clear comms where i live.

    I have the same problems with RPI gui but not the none GUI version. I never have any problems with esp.

    whats the easiest way to connect to regular UK wifi channels?

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.