We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

omega2+ gone non-responsive

  • @Michael-Mayo No. Please forget the Hardware Reset (pin5) now.

    Did you connect these seven (7) pins - 1, 22, 63 to GND and 8, 9, 32 to 3.3V and pin5 NC - well?

    You wrote:

    Serial port console (TX0 pin 12 of surface mount package), on startup, has this.....

    So you have a Serial Console and wanted to write this:

    Serial Console (pin39 ie. GPIO_12/UART_TXD0 of surface mount package), on startup, has this...

       ____       _             ____
      / __ \___  (_)__  ___    / __ \__ _  ___ ___ ____ _
     / /_/ / _ \/ / _ \/ _ \  / /_/ /  ' \/ -_) _ `/ _ `/
     \____/_//_/_/\___/_//_/  \____/_/_/_/\__/\_, /\_,_/
     W H A T  W I L L  Y O U  I N V E N T ? /___/"
    Board: Onion Omega2 APSoC DRAM: 64 kB
    relocate_code Pointer at: 7ff70000

    Power On your Omega2S+ and let us know the full Serial Console log please.

  • @György-Farkas This is the entire serial console output....

    / __ ___ ()__ ___ / __ _ _ ___ ___ ____ _
    / // / _ / / _ / _ \ / // / ' / -) _ / _ /
    /////___//// _////_/_, /_,/
    W H A T W I L L Y O U I N V E N T ? /

    Board: Onion Omega2 APSoC DRAM: 64 kB
    relocate_code Pointer at: 7ff70000

  • @Michael-Mayo
    GND on 1, 22, 23, 63 only
    +3.3v on 8, 9, 32
    3.3v serial connected to 39 (driving to computer) and 40 (receiving from computer)
    All others NC

  • @Michael-Mayo The other omega2s+ that I have powered up lights the led on pin 19 (this "bricked" one does not) and puts out many lines of boot messages to the console port at pin 39. This "bricked" one stops at the "relocate_code" line.

  • @Michael-Mayo
    How is the reflash done?
    Or is this really a dead device?

  • @Michael-Mayo Hopefully the second one will work well.
    I'm only guessing - probably the first one did not survive your soldering process.

    The HW_RST_N (pin 5) (ie. the Hardware Reset Input) does not work on Omega2+ / Omemega2S+ at all.

    You should make a Software RESET BUTTON:
    GPIO_38/SW_RST (pin 4) --- 1 kOhm resistor --- a normally open momentary push button --- +3.3V
    If Omega2 successfully boots press this button - a short press will Reset it - a long press will perform a Factory Reset

    When @William-Scott wrote above

    "Reflash" the device.

    he only wrote about the Factory Reset / Factory Restore scenario.

    If you really want to reflash your device you need to make - for example - a software RESET BUTTON and a USB Host Port.
    If you really want to reflash your device you need to have - for example - the Serial Console, the software RESET BUTTON and the USB Host Port.
    Firmware Flashing from USB Storage

  • @György-Farkas Now I am back from deploying the project. The second Omega2s+ continued to work beautifully. The first one did work beautifully, in the lab, until it croaked. As you suggest it may have been a victim of soldering other parts of the system, ESD, that sort of thing.
    I have tried the SW_RST (software reset button) as you suggest. It makes no perceptible action at the console serial port or anywhere else visible. Perhaps it has hardware damage.
    The console serial port is working. It still produces the boot start message pictured above. (ending 7ff70000)
    Is there a schematic for connecting USB storage to the Omega2s+ for reflashing?
    Just connect to pins 61-63 and give the USB storage device some +5v?
    But I think I should be seeing bootloader messages at the console port. None are there. Does this mean the device is really dead and my boss is correct in saying I should just buy another one and not waste my time on one that I have killed?

  • @Michael-Mayo said in omega2+ gone non-responsive:

    Is there a schematic for connecting USB storage to the Omega2s+ for reflashing?
    Just connect to pins 61-63 and give the USB storage device some +5v?

    Yes, connect:

    Omega2S(+) USB type A (female) conn. Power supply
    USB_DM (pin62) USB Data-
    USB_DP (pin61) USB Data+
    VCC +5V

    See also the USB Host Port on the Expansion Dock: WITHOUT EXPANSION DOCK...

  • @György-Farkas Very nice. Thank you.
    Seeing as the boot console output does not go beyond "relocate_code Pointer at: 7ff70000" do you agree with my boss that it is time to abandon this particular broken part and buy a new one? (actually I have a spare)
    My understanding of the process is that the USB cannot be used for this purpose if the console port does not respond.

  • @Michael-Mayo Let me throw in my 2c worth.

    If you worked for me and the SOC costs me $20 and your time costs me $30/hr I'll give you 1/2 hour at most to resolve this or throw it in a box and use a new SOC.

    The USB @György-Farkas suggested costs a few dollars + shipping I would expect, so if you're spending time on this we're moving backwards.

    Only if we have multiple devices experiencing this issue such that it would be financially beneficial to be able to fix them does it make any sense to spend time fixing them. This is why large manufacturers prefer to replace failed products than repair them.

    Later when you have down time where the current queue of work is empty, it might be beneficial to my company to pay you to better understand and/or fix the issue.

    Personally I have 30+ Omega2S+ mounted on experimental PCBs sitting in a box. When I have nothing else to do I'll recover them and probably reuse them on demo devices.

    Opportunity cost is the true cost of being too pedantic in fixing every failed device. As a technologist I want to understand and resolve every problem I come across, but if I had fixated on that over my 40 year career I'd be living on skid row instead of lving a very comfortable life.

  • @Michael-Mayo

    1. You have a well working Omega2S+ - this can be your "reference" device.
    • You can watch the messages of the whole boot process on the Serial Console.

    • Moreover you could enter into the UBoot (the botloader) menu of this device:

      • switch the power off
      • press and hold down the reset button (SW_RST)
      • switch the power on and a little bit later release the button
        and you should see something similar on the Serial Console:
       ____       _             ____
      / __ \___  (_)__  ___    / __ \__ _  ___ ___ ____ _
     / /_/ / _ \/ / _ \/ _ \  / /_/ /  ' \/ -_) _ `/ _ `/
     \____/_//_/_/\___/_//_/  \____/_/_/_/\__/\_, /\_,_/
     W H A T  W I L L  Y O U  I N V E N T ? /___/"
    Board: Onion Omega2 APSoC DRAM:  128 MB
    relocate_code Pointer at: 87f60000
    flash manufacture id: c2, device id 20 19
    find flash: MX25L25635E
    Onion Omega2 UBoot Version:
    ASIC 7628_MP (Port5<->None)
    DRAM component: 1024 Mbits DDR, width 16
    DRAM bus: 16 bit
    Total memory: 128 MBytes
    Flash component: SPI Flash
    Date:Oct 18 2016  Time:17:29:05
    icache: sets:512, ways:4, linesz:32 ,total:65536
    dcache: sets:256, ways:4, linesz:32 ,total:32768 
    CPU freq = 575 MHZ
    Estimated memory size = 128 Mbytes
    Resetting MT7628 PHY.
    Initializing MT7688 GPIO system.
    * Hold Reset button for more options *
    You have 40 seconds left to select a menu option...
    Please select option: 
       [ Enter ]: Boot Omega2.
       [ 0 ]: Start Web recovery mode.
       [ 1 ]: Start command line mode.
       [ 2 ]: Flash firmware from USB storage.

    1. You have a probably dead Omega2S+.
    • You see only a few messages on the Serial Console:
      I think your main problem is that you have got this message
      "Board: Onion Omega2 APSoC DRAM: 64 kB"
      instead of this one:
      "Board: Onion Omega2 APSoC DRAM: 128 MB"
      It seems something bad happened during soldering with the PCB and/or the on board RAM (it has BGA package!).
      BTW I don't have - and never had - such damaged device so maybe I'm wrong.

    • Please also try to enter into the UBoot menu of this "dead" device.
      It is mandatory to reflash the firmware (ie. replace the corrupted FW with a good one) - if your HW is not damaged.

  • @crispyoz Another user suggested the firmware reflash (not me;) therefore OP wanted to reflash a "dead" Omega2S+.
    I wrote about the necessary HW components only.

    Your point of view is quite interesting that a USB type A connector for a custom Omega2 USB Host Port (plus its shipping cost;) is some expensive HW component.
    Is a "back step" indeed?

  • @György-Farkas I was just responding to Michael's point "... do you agree with my boss that it is time to abandon this particular broken part....."

    Not particularly that a USB A port and shipping is necessarily expensive, just that it adds to the cost of investigating and repairing the $20 part. As a boss, if I'm paying you a salary I need a return on my investment, if I'm throwing good money after bad just to fix a $20 part, it makes no financial sense if it costing me more than few dollars in labour to fix it.

    I may take a differnt view if we had multiple devices failing in the same way and we needed to better understand how to fix them since in such a case the financial risk is potentially more significant.

    Recently I ordered 20 Omega2S+ from a well known supplier, they packed them in some unsuitable packaging trays such that many got loose and were all banging into each other over their 10,000km journey to my office. I reported the issue, they sent me replacement units and told me I could do what I wanted with the old ones. It would have cost them more to quality check each potentially damaged device than it did to simply send me replacements.

    Maybe when I have time I'll put those potentially damaged SOCs on boards and test them and maybe deploy them in non mission critical situations. But only if I have nothing else to do or despirately need some new SOC.

  • @György-Farkas Thank you.
    This is all that happens when I power it up with or without the reset button pressed.
    I now conclude that it is dead and not recoverable. So I will leave it at that and consider the learning has been useful.

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.