We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Missing nosys.specs

  • Hi All,

    I am using the docker image that has the toolchain setup for the Omega. I am receiving the following error.
    mipsel-openwrt-linux-g++: error: nosys.specs: No such file or directory
    Is there a update or fix for this? Anybody else run into this issue?


  • @John-Smith-0 run make -j1 V=s to get more visibility of the issue.

    Have you run: sh scripts/onion-minimal-build.sh

    The error relates to a compiler switch which may be specific to a package you are compiling, if you use the minimal build it may resolve your issue.

    We need more logs to troubleshoot further.

  • Hi crispyoz,

    I did not locate the onion-minimal-build.sh file in my scripts folder, however I was able to run the command you suggested. Please see the results below.

    CMake build is: RelWithDebInfo
    ASIO has been checked out as a git submodule: /projectfolder/openmodbus/deps/asio/asio/include
    -- Configuring done
    -- Generating done
    -- Build files have been written to: /projectfolder
    [ 11%] Built target openpal
    [ 96%] Built target openmodbus
    [ 96%] Linking CXX executable OpenModBus.out
    mipsel-openwrt-linux-g++: error: nosys.specs: No such file or directory
    make[2]: *** [OpenModbus.out] Error 1
    make[1]: *** [CMakeFiles/OpenModbus.out.dir/all] Error 2
    make: *** [all] Error 2


  • @John-Smith-0 did you run these commands to complete your setup :

    ./scripts/feeds clean
    ./scripts/feeds update -a
    ./scripts/feeds install -a

    ln -s .config.O2 .config

  • I ran the commands you suggested above and retrieved the latest updates. However, the onion-minimal-build.sh was not created in the scripts folder. I also attempted to run make again and still have the same error as above.


  • @John-Smith-0

    Take a look at this thread on setting up CMake for Docker and Omega, maybe it helps.

    nosys.specs is used in a cross compiling environment where the host is not available such as when you are compiling on linux to deploy on OpenWrt. When openmodbus is being linked it seems it cannot find the required library stubs. You need to look to see what it is linking with, I don't use CMake nor OpenModbus so I cannot check.

Looks like your connection to Community was lost, please wait while we try to reconnect.