We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

mmcblk0 "error -145" (sdcard)

  • I've tried 2 different cards now on my Omega2+, (8GB and 32GB), and whenever I insert either, I get a bunch of errors about failure to read blocks. They're both formatted ext4, and both work without issue in other devices. Is it possible my Omega2+ has a faulty SD reader, or is this a common problem? I know they're inexpensive, but if this is a known issue, I'd prefer not to throw good money after bad.

  • @William-Allen What firmware version are you using? Are you using your Omega2+ on an expansion board?

    My experience with sdcard failures have always related to one of two issues. 1) Insufficient power; 2) poor seating in the expansion card, which probably was causing insufficient power.

    On the Omega 2S+ I've had issues with a poor ground connection on my custom board so I think the general pattern of the issue is one of power supply.

  • @crispyoz Thanks for the response!

    Yes, an expansion board, using the latest firmware. I already reseated the controller after inspecting the SD slot for any obvious signs of damage.

    I'll look into the power issue. If I connect, say, a 2.4A charger cable to the microUSB slot of the expansion board, should that provide sufficient current, or should I feed the MCU v_in pin directly from a power supply?

  • @William-Allen 2.4A Micro USB supply made no difference. Not sure if the input is current-limited somehow. Also, USB thumb drive works fine, and I'm guessing that draws more current (of course not through the MCU...)

  • @William-Allen From my experience there is no underlying issue with Omega and SD Cards, all of my IoT devices have SD Cards installed and I have a large numberof them out in the field.

    2.4A is plenty, however not all power supplies are created equal, there is a lot of "less than ideal" power supply devices on the market. I would try powering the device using different sources and see if this improves things.

    Others may be able to provide other tips to assist you.

  • Thanks crispyoz. I tried a few different PSUs and reflashed the firmware, but no luck. I ordered a couple more so hopefully I'll have better luck with those.

Looks like your connection to Community was lost, please wait while we try to reconnect.