We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Power Omega2 from 3.7 volts?

  • Ultimate magic smoke (UMS) story: The summer prior to my senior year in college I was in a salaried position as Student Engineer at Inland Steel in the No.1 Electric Arc Furnace and Billet Caster (a continuous caster). The prior summer, the 1F cap story, worked in the No. 3 Basic Oxygen Furnace and Slab Caster, the number 1 steel making shop in the world, not just then but also now.

    Do a web search on continuous casters and find some YouTube videos if you can. They are fascinating....and potentially dangerous as you're about to find out when a 21 year old has control system schematics and a pencil.

    The continuous caster control system was in a room perhaps 15m by 10m with most walls covered by enclosed racks of equipment including a bajillion relays. The schematics are a mess, outdated and staff members were concerned about using them and erroneously "fixing" something resulting in a disaster. My job was to red-line the schematics to bring them up to date. So, I have schematics, a pencil, and a multimeter and I'm in the caster control room. There's a door at both ends of the room with the caster, in operation, only about 2 to 3m beyond one of them. I get to work.....with the caster in operation. What could possibly go wrong here?

    I'm frustrated, but need to make progress. I think one circuit could be validated if I close this one relay and I'd see just this one other relay flop in an adjacent panel (can anyone guess where this is going?). So I have both panel doors open and find both relays. Using my pencil eraser I close the target relay while keeping an eye on the other.. Then it seemed like there were several hundred relay closures in the room all around me....and it kept on happening!!!! Then a siren alarm sounded....then I looked at the door at the caster end where a red light was flashing.....then I saw molten steel bouncing off of everything.....then I saw two guy run by the door apparently trying to save their lives....then I saw more molten steel fly around all over the place. Oh...my....I just caused a breakout....a phenomenon created when the caster is sped up such that the steel can't form a cooled shell before leaving the mold, so the internal molten contents started spilling onto the floor. Damn! My 21 year old frustration almost got people killed!!!

    So, I didn't let the magic smoke out, but I made a very, very big error! There was some water around and some oil & grease, so there was some smoke and a whole bunch of steam. I'll never forget that and it was in 1980!!

    Here's the punch line, and it is crazy. After a few weeks I admitted to my boss that I thought I caused the breakout and explained to him in graphic detail. His response to me? "You know what, Bill? We consider you a virgin until you destroy at least $50,000 worth of equipment." Feel free to jump on-line and find one of those inflation calculation tools to see what 1980's $50,000 USD is worth today. You will be stunned!

    There's my best magic smoke story, and I was still a student at the time.

    take care all!

  • @crispyoz LOL....really LOL! I am really laughing! You are brilliant!


  • @crispyoz I see it's 15 minutes later and I'm still laughing! However one part of my brain asked if this would be $100k USD or $100k AUD.....and that also cracked me up even more!

    Anyone else want in? As you can tell by our stories, magic smoke escape is a serious problem. If you're experienced at blowing stuff up you might be just the kind of person we need on the team!


  • Ah yes. I have one too! This is from the mid 1960s.

    I was studying Electrical Engineering and during one vacation was working at what was called the "Postmaster General's Department" in Australia (they had provided me with a scholarship). In other words, Posts and Telegraphs encompassing communications such as TV, phones and even the ordinary mail.
    Anyway, my boss, the Chief Engineer decided to give me some field experience. So I went to a facility high in the mountains. It was a sort of relay station for microwave links between Sydney and Melbourne. Very important as it (as well as TV) carried all telex, phone calls etc between capital cities.

    The local engineer showed me the various workings, including the triple redundancy with lots of stuff. He proudly opened one rack with multiple power supplies and various transmitters & receivers.

    I said "So, if any one of these rack units fails, another one will automatically take its place?" "Yes" he replied.
    "Can I try it?"
    So I did. I pulled out one of the rack units and all was good.

    Then I tried to put it back in and somehow got things crooked and pushed way too hard (I was a strong guy).
    There was a huge "bang". A huge flash. Sparks flew everywhere.
    Then- dead silence. All dead. Everything dead (except the humans)! It was pitch black (no windows in there).

    After one minute's silence (during which I was seriously considering if I had any future), a couple of dim light bulbs came on. Then all seven bright red phones started ringing. Then a huge (about 100kW) generator started up. Then various lights came on.

    I had wiped out everything. But they got telephones, telex and stuff going in about 10mins. But Television took until next day.
    That was the end of my work experience in the field. The rest of the time, I was confined to HQ with a drawing board updating diagrams!
    Like the molten steel-never forgotten.
    Also, I learned something about systems which allegedly can never fail......

  • @David-Kerr OMG!! Definitely one of those things you can never forget, no matter how hard you try! The "...I was confined to HQ with a drawing board..." just made me bust out laughing! We are indeed brethren in causes of industrial disasters!

    Television the next day.....OMG!

    So, @CAP-33, see what havoc we can create when we're trying to do the right thing? Just imagine if we didn't care...... 8^o


  • @CAP-33, you should look at schematic Power Dock 2 expansion shield.
    But Omegas take much power and doesn't have power management subsystem. You have to use a big Li-Pol battery or change MCU Like ESP8266 instead.

  • I am running five different Omega2+s off 3.3V 1A SMD regulators. You need to supply brief peaks of current for the WiFi. But the average is less than 300mA. Well within the capability of a LiPo 18650 or a couple in parallel.

    I also have two Omega2+ Dashs and they are running just fine off a TO220 LM3940 and are drawing 240mA average at 3.3V.
    I have a couple of other Omega2+s running off 12v:3.3v 1A Texas Buck converters. All good. The Omega2+ Dash from the factory uses a 5:3.3 switching regulator rated at 1A when running off USB.

    So, I see no problem using a single 18650 LiPo through a LM3940 1A LDO regulator. Just add a couple of capacitors per the LM3940 datasheet and I'd also add around 100uF ceramic or tantalum at the input of the Omega2+. There is no point using a switching regulator given the LiPo will be operating between about 3.2 and 4.2V (the latter briefly). Make sure to have LiPo protection either in the cell or in the charging.


    Edit: Corrected incorrect LM2940 to LM3940

  • Okay, to illustrate (for anyone wanting to run off a LiPo cell), I quickly knocked up a Lipo with LM3940 regulator. Works fine with the attached Omega2Dash doing WiFi networking over 2 UDP sockets once per second plus running an App I've made with LVGL. Here are some photos.

    The LM3940 has a 0.47uF ceramic on the input and a 68uF tantalum on the output. In this case, it is driving the Omega2+S plus the Dash display. I have a separate post about connecting to this part of the circuitry (search for 3.3V and 5V and Dash). Cost A$1.80or US$1.00.

    The small PCB is a TP4056 based LiPo protection and charger board. Cost A$2.40 or US$1.40.

    This cell should run the Omega-Dash for around 10hrs.


    Edit: Corrected incorrect LM2940 to LM3940


  • @David-Kerr Awesome report!!


  • Nice article @David-Kerr thank you !

  • Thanks to everyone for the answers and interesting stories! I solved my problem by applying the DS-DS converter LM2596.

  • Hi Cap33,
    Glad you solved you problem. Good also that your Omega presumably still works after direct connecting the LiPo cell. However, if you are using a single 3.7V LiPo the input voltage is out of spec (too low) for the LM2596. LM2596 would be fine from about 4.75V upwards (so USB 5V, 12V et al). So if it works then that is more by good luck than anything else. Also a more expensive solution than a cheap LDO linear regulator.

  • Okay. My 2600mahr LiPo ran the Dash for just over 9 hours. The LiPo was at an average of 15degC which derates the capacity to 2400mahrs. So I would expect 10hrs, so just over 9hrs is not too bad. The reason for the discrepancy is that the tail of the LiPo discharge cannot be used because the LDO cutout is about 0.1volts, so when the LiPo hits <3.4V the Omega2+ starts to misbehave. Total consumed energy was 8watthrs and "wasted" energy 0.86watthrs.

    You could expect 24hrs continuous running with 2 high quality 18650 LiPos having higher AH rating.

    Hopefully this is useful information for people contemplating putting the Omega2+Dash into portable applications.


  • @David-Kerr
    I opened the datasheet on the LM2940, but it says that the output voltage is from 5 to 15 volts.

  • I am so sorry- my old (73 year old) eyes are not so good any more. They are LM3940; I misread the 3 for a 2 but had the correct datasheet and did not look closely at the 2/3.

    The voltage differential is 0.110V at 100ma and 0.5V at 1amp. However at around 240ma the differential is about 120mV. The capacitors absorb any surges (e.g. from the WiFi). So you still get 3.3V out until the LiPo drops to 3.42V. The Omega starts to misbehave below about 3.2V, depending upon production spread.


    Edit: I also suggest looking at Texas Instruments or National Semiconductor datasheets rather than generics.

  • Okay, here's a little more information. I have measured my LM3940 and the voltage drop is only 90mV. So better than the worst case spec.

    See thread


    If powering an Omega2-Dash, you can use the onboard switching regulator and this saves a further 15mA of drain and (in my case) should add an extra 30mins of battery life.

    You could use the OmegaDash switching regulator (or similar) with a normal Omega2 or S because it is LDO (Low Drop Out) but it is more components and cost. So if I was adding extra circuitry and a PCB to a portable Omega2 device, I'd use the switching reg but if only supply power I'd use a LM3940 (or similar) LDO linear regulator.

    So, for my Omega-Dash units, I'm using the onboard 5V input fed from the TP4056 and the LiPo connected to the TP4056. Charging from the TP4056 USB/5V input.

    I've gone back and corrected the 2940s to 3940.


  • @David-Kerr
    I bought an LM3940, put an output capacitor with a capacity of 220 microfarads, but Omega does not start even with an input voltage of 5 volts. The orange LED starts flashing, but turns off after a few seconds.

  • @CAP-33 , have you checked the output voltage and monitored it when the Omega2 fails the boot process?
    What is your power supply ? Can it supply enough current?
    Do you have a 0.47uF input capacitor on the LM3940?

  • I assume you are running from a 3.7V cell as well as trying a 5V power supply?

    One other thing. What package LM3940 are you using? I used a TO220 with no heatsink (as you will have seen in the photo), which was fine. On some of my other projects I am using SMD LM3940s from 5V to 3.3V with Omega2+ and Omega2. They definitely need heat-sinking or they will heat up and then likely shut down after a while.

    Let us know how you go.


  • @David-Kerr
    First I'm running from a 3.7V cell, and then trying a 5V power supply. I use TO220 with no heatsink. After several measurements, I noticed that the output of the LM3940 has 3.28V without load. When I connect Omega, the voltage drops to 3.1V, which is not enough for Omega.

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.