We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Running a server, but having Firewall problems



  • Finally decided to make use of my original omega and the relay expansion last night, and thru a lot a of trial and error squeazed a Ruby sinatra app in to the disk memory constraints.

    Now the server is running, on port 4567, but it's inaccessible on my local network.

    I've added this rule to /etc/firewall.user and restarted the firewall but so far it's not working:

    iptables -A INPUT -p tcp -m tcp --dport 4567 -j ACCEPT
    


  • @Dan-Diemer what firmware version are you using? What Omega device are you using?

    Step one is always to stop the firewall and check your app communicates correctly. /etc/init.d/firewall stop



  • @crispyoz great idea! It's been a long time since I've done any firewall troubleshooting!

    It's the original omega running firmware 0.1.4 (b330)



  • @crispyoz ok, stopped the firewall and it made no difference. Pulling up the page still shows that it can't be reached. Nmap still shows port 4567 closed.

    Is there another firewall running? I didn't see any rules anywhere allowing port 80 for the web interface.



  • @Dan-Diemer I'm confused about your comment about port 80 and port 4567, are you forwarding port 4567 to port 80? Sorry I don' t know sinatra, other than Frank.

    Can you access your app on the local device? If so maybe your app is bound to the port on the local IP but not the public IP. Have you looked at netstat -a to see who is listening?



  • @crispyoz sorry for the confusion. By port 80 I meant the webserver that runs by default on the Omega to show you the web UI with the settings and terminal apps, etc.

    I'm trying to keep my Ruby sinatra server running on port 4567, no forwarding.

    I think you're on the right about it being bound to the wrong ip. I'll dig in to that. Thanks again!



  • @crispyoz that was exactly it! I had forgotten to tell the app to run in production mode so it was only listening on localhost. Thanks for the great tips!


Log in to reply
 

Looks like your connection to Community was lost, please wait while we try to reconnect.