We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Installing Terminal, Editor, etc...

  • I was helped graciously to reset my Omega2+ back to factory settings, and have begun trying to get into setting up the device. My first order, installing the Terminal and Editor apps, has been met with an aggravating dilemma. Normally, selecting these from the home menu would have you install them, then refresh the page to have them display right. However, I've tried multiple times and despite it saying that the apps are now installed, it asks me all over again to install.

    I've tried Opera, Edge, Firefox, and now Chrome for this, to no avail. I would change the Wifi to mobile data on a smart phone, since that would be faster, but after ten minutes, the "Wi-Fi Settings" section has yet to proceed past the buffer icon.

    Does anyone know how to circumvent these problems? Any and all help is appreciated, as always.

  • @Scruffy the first thing would be to ensure you are on the latest firmware version. What version is currently shown ?

    If you want to connect directly to the device via a terminal, download Putty and ssh to, login as root/onioneer then type wifisetup

    Then follow the prompts to configure your wifi. Once connected to your home wifi you can run oupgrade to update to the latest firmware.

  • Factory reset, so it's on firmware v0.1.5 (b130), trying to update it to 0.3.2 (b233). I don't know how long it usually takes, but it's been a bit over half an hour, and the download seems to get stuck around 1/3 progress.

  • @Scruffy that's a very old version so I would approach this a different way. What type(s) of dock do you have?

  • Mini dock.

  • @Scruffy This would be my approach.

    Check first you can connect to your device via USB-serial:


    Then download the latest firmware on your windows/linux/mac device and place it on a USB stick. Then follow the instructions to flash the device via USB:


    Key point here. Make sure you rename the downloaded firmware file to omega2.bin on the USB stick or the system will not find it.

    While these steps might be painful right now, once you have these steps under your belt you will have a better understanding of how to resolve a range of issue on your device.

    Please let us know how you go.

  • @crispyoz Installed a couple of things to launch the Omega material without turning it on. I'm at "Step 1: Check if the serial drivers are already installed", but when I use PuTTY to launch the port Silicon Labs is under (COM3), the window that comes up doesn't allow anything to be typed in, and goes inactive after about ten seconds.

    Edit: My guess is that it's not managing to connect to the server, which is why it doesn't relay either a login prompt or welcome message.

  • @Scruffy if you reset the Omega and then reconnect to the terminal, COM3 in your case, you should see the boot messages. If not then you are not connected. What configuration do you have on COM3? It should be 115200 baud, 8N1. You should have both RTS and DTR off.


    If this doesn't work I would check your power supply, you need a 2A supply or strange things can happen.

  • What I currently have is what's below. It is the same setup I see in your window, aside from the serial line option. It just returns the Windows error sound when I click to proceed.
    Is there a particular way to find what the power supply amount is?

  • @Scruffy
    Most power supply have the specs on a label somewhere.
    Also are you sure COM3 is correct? I think you are using windows, if you look in the device manager you can see which port serial ports you have. Just use Run, type devicemgr it will open the device manager, look down for the "Port (COM & LPT)" expand it and see what serial ports you have. Windows may have changed he assigned port from COM3.

  • I don't know about the power supply, then. I simply plug the Omega2+ and mini dock into a micro-USB cable, into the computer's USB. But yes, I did recheck, and the only port available comes up when I plug the Omega in: "Silicon Labs CP210x USB to UART Bridge (COM3)"

  • Probably the internet speeds at my residence (<50 Kb/s). Currently downloading materials for school at the library, and gave it another go, and I managed to get the terminal up and running.

    Keeping my fingers crossed. It's currently at "random: nonblocking pool is initialized".

  • Update. I believe I've properly gone through the process a couple of times, launching the terminal and then opening the Omega2 and using bootloader to upgrade from the USB device. However, when it finishes, it's still on v0.1.5 b130. It may be because I pressed enter by accident, but on the other attempt, I waited over ten minutes without any progress past "random: nonblo...."

    In case the power supply is the issue, what is a safe and reliable power supply for the Onion Omega2+ and Mini Dock?

  • @Scruffy without being able to see your log it is hard to see what is going on.

    Here is another approach. Copy the firmware file from the USB to the /tmp directory on your Omega.

    Your USB stick will be identified in the boot messages but you can usually use df -h and find the device will be something like /dev/sda0 or /dev/sda1

    Copy the firmware to your /tmp directory like this:

    cp /dev/sda0/omega2.bin /tmp

    Now run the upgrade:

    sysupgrade --force /tmp/omega2.bin

    Regarding power supply, you need 2A so if you have an iphone plug from a later model that will usually suffice. Usually your computer USB port should be fine but when troubleshooting wifi or any strange issues it's always usual to check your power source. Try the firmware upgrade method above, you're using a very old firmware version so that is most likely the issue.

  • So, the flash drive in regard is labelled as 'sda1', so I changed that part, as well as the file name, to use the given command.

    cp /dev/sda1/omega2.bin /tmp

    I checked it several times by plugging the flash drive directly into the computer, making sure the file itself was there in root with the right name I used. I kid you not...it says there's no such file in the directory.

    The only other thing I can think of is the power supply. I put in an order for a different dock to use, the one that ensures a steady, safe supply, so perhaps that can fix this.

    I'm afraid to ask the terminal what 1 + 2 is. With my luck, I'd probably get "Eli Whitney" for an answer.


    I took a careful look with the directories displayed with df -h. There are two lists in the table they give, and the command we tried addressed the wrong one apparently.

    cp /dev/sda1/omega2pro.bin /tmp

    This one calls upon the "Filesystem" directory. When I tried redirecting to the "Mounted on" directory (other end of the df table), we get something like this:

    cp /dev/mountd/sda1/omega2pro.bin /tmp

    This, it recognized. Possibly because that's where the flash drive is, well, mounted. Afterwards, the firmware upgrade went without a hitch, and we are now working with v0.3.2.

    Thank you for all the help over the past week, troubleshooting and whatnot. I very well may need more when it comes to a project or two I'm looking at, but that'll be for a different discussion post.

  • @Scruffy That's good news, patience and perseverance paid off. The omega2pro.bin is for the the omega pro model, but your post said you had an omega2 with minidock. Also in my earlier post explaining how to update from USB, I made the point:

    "Key point here. Make sure you rename the downloaded firmware file to omega2.bin on the USB stick or the system will not find it."

    So it all starts to make sense now. Onwards and upwards!

  • Right, noticed that. Meant to use the omega2p.bin file on the webpage. Explains why the Omega is broken now.

    Fixing now with the proper .bin file.

Looks like your connection to Community was lost, please wait while we try to reconnect.