We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Never have been able to use Omega2+ I received

  • Hi folks,

    I was an original KickStarter backer at the highest level. I saw great promise in this and invested over $500 in the project. I received a large box full of goodies, several of each item tha was available at the time.

    Thank you Onion folks, but I have never been able to use any of it.

    I have tried the web based setup and the CLI setup functions. I have never been able to get WiFi working. Ever. The web setup is totally useless. Using SSH I have gotten far enough that my router assigns the device(s) an DHCP IP address, but it is still not accessible on the network.

    The onion-xxxx SSID never stops broadcasting, and the only way I can access the device is to use its 'network'. But that is useless.

    It seems the WiFi range of these is about 3 feet. I have to have the devices close to my laptop to access (or even see) the Omega SSID. Maybe this is the problem. It can't successfully negotiate a decent connection to my AP because it is mounted on the ceiling 6 feet away. Too far šŸ˜ž I have tried 4 networks with SonicWall, TPLink, Ubiquity and MicroTic APs. I have various routers. I am a professional programmer and have had no problems with the 20+ other types of IoT devices I have used or built. But the Omega is a total bust.

    I decided to give this another try this weekend but it's always the same. Is there any page or third party site that will help people who received a box of bricks?

    After spending over $500 on this and getting nothing but unusable gear, I never invested in a Kickstarter campaign again. That was it for me.

    If anyone has any suggestions, I am happy to try anything. I hate to just toss it all in the trash.

  • @bigdogsb Sorry to hear about your issues. I've had great success with the products and have them in projects for revenue.

    Which dock(s) are you using?

    Have you put a terminal on tty1 to see what the console says at boot time?

    Do you have adequate power? This has been a big gotcha for many, many users. There's a big surge in current consumption as the WiFi modem comes up. That surge must be met or the device will not complete boot up.


  • @bigdogsb, you have to know it's a home-based device and OpenSource OS. Also you must be a very good Linux-user or admin to get maximum abilities from device. OS is very good and stable, there are many network's features.

    You listed several bugs, but it's for home using.

    • Web-interface as for me - no need at all;
    • AP doesn't turn off - many users know that, it the bug;
    • Not stable Wi-Fi connection - we all know it. For example my MIUI router from time to time no want to connect Omega2 then I reboot him (router).
    • You have serial UART terminal to tune device if be able any problems with SSH.

  • @bigdogsb :

    After reading your post, I switched to Omega2+ to provide gateway service to my primary workstation. The Omega is using a Linksys WiFi as its gateway, and is powered with an expansion dock.

    The connectivity is:

    WS (WiFi) => Omega2+ (AP+STA) => Linksys => Internet.

    It is more than 5 days since my experiment started; and the workstation was never shutdown. Here is the last dmesg line from the workstation:

    [502020.417869] usb 2-1.6: USB disconnect, device number 89.

    When I check the logs, I don't see any WiFi related problems. Needless to say,I never had any connectivity problems while using the workstation.

    I can access the Omega2+ (and the Linksys as well), using my cellphone from about 100 feet away, two dry walls in the middle.

    I use an apple A1400 power supply (5V, 1A) using the expansion dock, to power the Omega. I also used the power supply that came with a Xperia without any problems. When I used another power supply, that came with another cellphone, I had problems.

    Bottom line is, Omega is stable wrt WiFi, as long as you feed it with a reputed power supply.

    I would advise you to carry out the following.

    1.Download the "omega2p-v0.3.2-b233.bin" from http://repo.onioniot.com/omega2/images/
    It is the b233 release of the firmware for Omega2+ into your workstation.
    So you have a backup for future use.

    2.scp or use a sd card to transfer the fw to Omega's /tmp directory

    :tmp# sysupgrade -n omega2p-v0.3.2-b233.bin
    from the UART0 connection. This will upgrade and reboot the omega.

    :/# wifisetup
    and select "1) Scan for Wifi networks". It will give the list of available WiFi APs, as below:
    Selection: 1
    Scanning for wifi networks...
    Select Wifi network:

    5.Pick your choice and provide the key, as below:
    Selection: 2
    Network: linksys
    Encryption type: psk2
    Enter password:

    That is all about the wifi setup. Once you get the prompt back, you can check the Internet connectivity by ping'ing some hosts in the Internet.

    It is advisable to change the default AP key of the Omega2+. For that execute:
    :/# uci set wireless.ap.key='your_new_key'
    :/# uci commit
    :/# /etc/init.d/network restart

    If you executed, the "uci set.." command before #4, the other two commands would have been automatically executed by the wifisetup.

    Let us know how it goes..


Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.