We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Omega2/2+ hangs while booting with hung WiFi



  • Hi all,

    This is a continuation of sharing of ideas with @crispyoz under the topic:
    https://community.onion.io/topic/4266/editing-updating-the-distfeeds-conf-file-through-terminal/24.

    3xOmega2 (of which 2 are 2+ models) were used to test the WiFi hanging problem while booting.

    1. 3xOmega2/2+ as above with docks

    2. All three were configured as STA, another AP providing gateway service.

    3. USB powered hub that can take the 5V supply from an external power supply. These devices have built-in power socket and the usual USB cable that goes to the computer for data exchange. The hub is powered using a 3A PS initially, that was later changed to 1A. All the Omegas were connected to the hub and booted and then powered-down using the "poweroff" command, keeping the dock's power on/off switch in ON position. This was to power all the Omegas at the same time by pulling out/re-inserting the USB power cable from/to the PS.

    4. The CP2102s used in the dock would still be registered as ttyUSBx in the Linux system, even after issuing the poweroff command.

    5. minicom running in a Linux station was used for the UART0 connectivity; any similar program can be used.

    6. Pull the USB power cable from the PS (keeping the PS hot) and re-insert after a few seconds.

    7. All the omegas are expected to complete the boot process as seen in this video:
      https://drive.google.com/file/d/1nrGuAQSY1XoJC86iTrtRMzCxPhrsQop3/view

    8. After booting, outbound connectivity is checked and then poweroff command was issued. The USB power cable was pulled out and re-inserted on the PS end to repeat the cycle.

    9. Try as many times until we get a WiFi initialization problem. WiFi initialization draws considerable amount of power and it can fail, if power supply is not able to provide enough power.

    10.Finally, I "overloaded" the PS by connecting USB Drives(they do draw power,right?)to the dock. This gave a boot failure for one Omega2+, which is uploaded here: https://drive.google.com/file/d/12udCFFuTlSrgCTRREVB2k_jU-_pr9Ms8/view

    Bottom line is, use a good PS that can stand load. I have done many many reboots with different PS (3.0, 1.5, 1.0 A) and
    the boot failure for Omega (ttyUSB2) occurred when the supply voltage dropped below 4.8 volt.



  • @tjoseph1 Good work! I'd like to re-emphasize for all newcomers that "power supply", as opposed to "THE power supply", is critical. Of course THE power supply must be able to satisfy peak current demand. The overall power supply also includes any cabling which may provide enough inductance that a power supply barely over the minimum required capability may be inadequate at the power pins of the Omega. It is only the available current at the Omega power pins that matter, not what an upstream subsystem can provide.

    --Bill



  • @tjoseph1 good analysis thank you for posting.



Looks like your connection to Community was lost, please wait while we try to reconnect.