We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Omega 2S+ Ethernet Connection Problem

  • Team Onion

    @akif-durmaz Hi ,please add a screenshot of the ethernet connector and transformer 's schematic.

  • @JeffZhou
    there was a product link in my original post but here, these are the only two pages from the datasheet;



  • Team Onion

    @akif-durmaz 1cca555a-1ce1-4e59-b50e-a24221e7ca0e-image.png
    Hi, i had checked the Normal ethernet connector(RJ45),it seems that the inside schematic isn't as the same as yours. Here the connector's sch has the same channel coil of RX/TX.SPEC of HR913550A

  • Team Onion

    This post is deleted!

  • Team Onion


  • @JeffZhou
    Unfortunately I have no idea what those differences mean. However I know for a fact that this connector works as I connected it with another device. So I think my problem lays under something else.
    Thank you for your interest and replies.

  • Team Onion

    @akif-durmaz Hi ,what i mean is you can try to use another ethernet connector.

  • Banned

    I am as yet looking for some appropriate arrangement!

  • Team Onion

    @Malcon4 Please check out the new Omega2S hardware design guide, there's a section on ethernet design!
    https://github.com/OnionIoT/Omega2/blob/master/Documents/Omega2S Hardware Design Guide.pdf

  • Team Onion

    @Malcon4 here is the ethernet port that Omega2 using . 阿里旺旺图片20201202171738.jpg Ethernet Port .png

  • Guys when you see a post that does not ask any specific question and/or does not offer any information, it is likely a "SPAM Probe". The user, usually a BOT is responding to a thread that is way out of date and making a boilerplate statement. They are looking for a response and/or checking if their post will get blocked/banned and how long that process will take.

    Let's keep the forums free of these guys by ignoring their posts until we have time to ban them.

  • @JeffZhou
    I couldn't answer due to a covid infection I was dealing with. Thank you for your suggestion, I guess I have no other lead, I will try another connector

  • After working on this for a while again, I'm now sure this has nothing to do with hardware. Can anyone point out something do with software that I should watch out for?

    I only made the following change in /etc/config/firewall on a brand new device

    config zone
    option name 'wan'
    option output 'ACCEPT'
    option forward 'ACCEPT'
    option masq '1'
    option mtu_fix '1'
    list network 'wwan'
    list network 'wan'
    option input 'ACCEPT'

  • @akif-durmaz up until now I see you have been looking at the hardware issue. What precisely is not workng?

  • @crispyoz
    I don't know how much you read but in short Omega doesn't have internet through ethernet.

    So basically I have a card with a working ethernet and another with a non working one. I also got an Omega2+ with expansion dock. So lastly I've tried to use each card with the others connector by soldering cables. My working card works with both of the connectors (as its own and when connected to the other card's connector), my non working one and my solo Omega2+ does not work with either of the connectors. So at the end I just assumed it was software related and the old card had some other configuration to connect through ethernet (Somebody else worked on the old card before me, who I can not reach anymore).

    Thank you for your response, let me know if I did not address something related I will try to be more detailed without writing too much

  • @akif-durmaz I read the whole thread, but I dind't find the details I was looking for.

    I'll assume there is no hardware issue, so I would test the software. Connect to your Omega using ssh so you have a console connection.


    Post output (again)

    The details you posted earlier in this thread showed no ipv4 on the eth0. i'm guessing the ipv6 is the default assinged to the interface so I'm more interested in the ipv4.

    Set a static ip for eth0, make sure you use an ip in the correct range for your LAN and correct netmask. Restart your device (or service network restart) now ifconfig again and check the ip has been correctly assigned to eth0. If so ping your router. What is the response? If you receive a valid response, try ping, do you get a response? if so now try nslookup www.google.com

    Post the results of the above so we can understand where the issue is.

  • @crispyoz
    First of all thank your for your guidance. Here are the ifconfig outputs;

    The non-working device;

    The working device;

    Both connected to the same network and have the same ethernet design and components. Working one is Omega2+ the other is Omega2S+ if it makes a difference.

    I'm quite inexperienced on the subject and we are nearing the friday evening here, I will try supply all the info you mentioned on Monday since I can't take the devices home.

    Thank you.

  • @akif-durmaz So we can see that the issue is that your eth0 is not being assigned an ipv4 address. If you look at the working device, eth0 has been assiged an ip, on the non-working device eth0 has no ipv4. So that is the most logical issue, as I assume you are not relying upon on ipv6.

    On the non-working device we can manually assign an ipv4 address and see if that connects you to your network.

    First make sure you have disconnected the working device as we will use the same ip and could be a clash.

    Run these commands in the console:

    uci set network.wan.proto='static'
    uci set network.wan.ipaddr=''
    uci commit network
    service network restart

    You may lose responsiveness on the console for about a minute while the network restarts, Once you are able, type ifconfig again and you should notice that eth0 has the ip of

    Now try to ping your router:

    ping 192168.8.1 (I guess this is the ip of your router)

    Ping google DNS server:


    Trace steps to google DNS:


    Post your results.

  • @crispyoz
    Yeah I noticed the ipv4 difference before but I though that was just the problem not something that would lead me somewhere, i guess that was silly of me.
    So before I read your last reply I started working on static ip myself. I've edited the /etc/config/network as the following;
    As a result all of the pings failed, but I forgot to take a screenshot, after that I did the steps you posted changing the static ip, here's the result;

    I don't know if it's expected but before setting the static ip ping to the router was responsive.

    Here's the really embarrassing part for me, I thought I got ping responses with my old device but now this is the result;

    I thought I disabled the wifi before but I probably did not. After this result I assigned a static ip to this device as well and now it doesn't get a response to the router ping too.

    I'm sorry for claiming that my old device was working properly, but I'm sure it did before, in my old office (different router).

    There is still the difference of not getting an auto ip but i guess the problem now lies in the router itself?

  • @crispyoz As a side note, my laptop can connect to internet with the same cable on the same port

Looks like your connection to Community was lost, please wait while we try to reconnect.