We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Newbie Problems!

  • Greetings to the Community

    After 4 years of having my Omega2 saved, I start with an IoT project that requires more than just Arduino. Then I unpacked my Onion2 and its MiniDock.

    I started with the steps to configure for the first time and I got excited, I selected my network with the SSID, I got to the point of updating the firmware and I chose the omega2-v0.3.2-b244.bin, and apparently it worked, since being connected by SSH I saw the process of loading and restarting my Omega2.

    Afterwards I restart and I could not do anything else, neither connect by SSH, console line, and not even load the firmware from the USB connected to the MiniDock.

    Some advice?

    For good references I am using.

    Omega Onion2.
    Tera Term (for hyperterminal by console and SSH)
    Windows 10.
    My local network is

    Muchas gracias

  • @FredyAlvarez My guess is that your firmware update had some kind of hiccup, have you tried to perform a factory reset using the reset button?


  • @crispyoz Thank you very much for your prompt response. Actually if I try it, nothing new happened yesterday.
    Today I connected Onion2 again and this appears to me in the SSH terminal.

    07127048-9dfb-4119-8c38-bd3209169a45-image.png image url)

  • @crispyoz Sorry, I can't connect by SSH, actually this connection is serial to the console. I'm using teraterm, at 9600 Bauds.

  • Team Onion

    @FredyAlvarez Hi ,you can use 115200 Bauds. and if the Omega2 runs ok, the serial log will show something.

  • @JeffZhou Thank you very much for your suggestion, unfortunately that BaudRate can not connect to the COM port.


  • @FredyAlvarez @JeffZhou is correct, you need to connect to the Omega via the USB connecter at 115,200 baud, the device is operating at that rate so if you terminal is configured for any other baud rate you will get the garbage you are seeing now.

    I haven't used Teraterm so this might be your issue, I think most users use Putty, I use Zoc myself as I prefer it's functionality.

    I would download and install Putty (https://www.chiark.greenend.org.uk/~sgtatham/putty/latest.html)

    Now you can try configuring putty per the image below. If you still have the same issue change your USB cable and try again.


  • @crispyoz @JeffZhou Thanks for the tips, but it no work for me.


    I changed the cable for a new one from my wife's phone, it didn't work either. I'm not giving up and will try a few other methods. The sad thing is that I had never used my Onin2, after 4 years kept in a drawer when I received it from the kickstarter campaign.

    Saludos desde México.

  • @crispyoz @JeffZhou
    Well, the only thing left to do was to change the USB, and apparently that was enough. But It start very fast and I didn't have the chance to start (selecting option 2) with USB.

    But I'll be back. Now is time to remember when I use OpenWrt in arduino Yún (remove brain spidy-webs). I know that my Onion2 has me great surprises to be able to implement my project of IoT in the cloud.

    Thanks guys !!!



Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.