We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

USB flashing error USB - ERROR: CTL:TIMEOUT

  • I am compiling Omega2+ software and I made a few changes that caused a kernel panic. So I am trying to flash back to stock using USB flashing method. It will detect the USB drive in the bootloader and start reading the file but it will error out with a timeout. The other post I found has a solution of custom firmware that fixes it but due to my issue of not being able to boot this is not feasible. I have tried at least 5 different USB drive all from different manufactures with the same end result. The drive is partitioned to only have a single 1GB partition formatted to FAT32 with omega2.bin being the firmware filename.

    Any assistance to get this working would be appreciated. In the meantime I have ordered ethernet expansion to do a web recovery.

  • How r u @jmztaylor !

    I am a newbie, although I have already 4 years with my Onion2, but I was saving it for a special project.

    I started the configuration process for the first time and now I think I damaged the firmware, I could not flash it from the USB either, as soon as I have a solution I will gladly let you know.


  • @jmztaylor This is a known issue, you can see it here in the Onion repo:


    The solution is to update the bootloader which requires the ethernet expansion.

    I do have a workaround but there is no guarantee this will work in your case, but I have successfully used it several times.

    The issue reported above is apparently due to the firmware image size when it is loaded from USB so if we can load the image from an alternative source then we can overcome the issue.

    You need to be connected to the serial console and have your USB key inserted to do this.

    Step 1. Boot the device and watch for the prompt to set the debug level, this comes and goes quickly so it might take you a few tries. You will notice it also mentioned "press f and [ENTER]" to enter failsafe mode, here is the prompt:

    Press the [f] key and hit [enter] to enter failsafe mode
    Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level

    1. Once you are in failsafe mode your prompt will be root@(none):/# . Now you can mount root using the command: mount_root
      Hopefully this works for you as it doesn't load up all the modules which are often the cause of boot failures.

    Now enter these commands:

    mkdir /tmp/usb
    mount /dev/sda1 /tmp/usb
    cd /tmp/usb
    sysupgrade omega2.bin

    If all goes well this will flash the device. Good luck!

  • @crispyoz said in USB flashing error USB - ERROR: CTL:TIMEOUT:


    Thanks for this. Unfortunately, I could never get the USB drive to mount. But that did give me an idea to throw it on the sdcard and mount that. And that worked perfectly. So thanks for giving me a nudge in the right direction.

  • @jmztaylor Well that's good news. I suspect your USB key probably has an issue if you cannot mount it. You could likely fix it so you could mount it by running chkdsk on a windows machine or using dostools on a *nix machine.

    I just add those comments for future readers of this thread, but the core issue you were having would be as I detailed above.

Looks like your connection to Community was lost, please wait while we try to reconnect.