We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Failed to connect Omega2+ via Serial Terminal

  • Hi there,

    I am in need for some help to actually be able to connect to my Omega2+.

    I took my dear Omega2+ from the shelf and wanted to use it for some IoT side project. However, I ran into some weird issues. So when I tried to start the Omega2+ I had connected a power cable through the micro USB port, and had switched it on. The LED on the Omega turned on and stayed like that without any blinking. Nothing shows up on the available network window so I am assuming it failed at the booting stage.

    So I started to read into it a bit to try to find some solutions and what came up most of the time to reinstall OS/bootloader is to connect the omega via Serial Terminal. So as you might imagine at this point, I could not even do that. I am trying to connect it to a windows 10 PC. Downloaded the driver for the serial communication from the onion doc page ( https://docs.onion.io/omega2-docs/connecting-to-the-omega-terminal.html#connecting-via-serial-windows , Silicon Labs CP2102 driver for Windows) which seemed like was installed just fine, but then nothing shows up on the device manager.

    So at this point I am not sure how can I unbrick this little omega as I can't connect it to my computer to flash it.

    I also tried holding on the RESET button for 10 seconds after switched it on, tried using different ports on the PC, used different USB cables, also tried to hold onto the RESET button before switching it on while keep holding the RESET button. I tried to connect it to a MacOS as well.... but nada. Nothing worked.

    Any help how can I install Silicon Labs CP2102 driver for Windows 10 successfully or if there is any other way to factory reset the Omega2+ without serial connection?

    Many thanks!

  • @cskocsis which dock are you using?

  • Hey! @crispyoz I am using the expansion dock. The dock works just fine with my other Omega2 I have.

  • @cskocsis Have you checked you are using the correct serial port? I have many many configured serial ports on my Windows10 machine as each time I plug in a different device it is detected as a different serial port.

    Once you have plugged in your device, check the windows device manager to see which com port is active. Docks don't always behave this way but it's worth checking. Is the device detected at all when the apparently flakey Omega2 is connected?

Looks like your connection to Community was lost, please wait while we try to reconnect.