We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

dhcp ipaddress not happening.

  • @crispyoz Hi sir
    i have connected the ethernet cable to onion omega2S+, but IP address not happening it is showing another IP address class range. i was tried /etc/init.d/network restart even though it's not working. My class range is 172.16.1.* range series.

  • @Nagarjuna-Reddy Are you using udhcp or dnsmasq?

    Please share your /etc/config/network

    Assuming you are using udhcp, your device configuration should be :

    config interface 'wwan'
    option ifname 'eth0'
    option proto 'dhcp'

  • @crispyoz a376fd8e-b70d-4e99-815f-0e20355a8aec-image.png

    this is what i am using in the network configuration.

  • @Nagarjuna-Reddy That looks ok but my other question was whether you are using dnsmasq or udhcpc, if you're not sure run ps and post the results.

    run service network restart then use this command:

    logread | grep -i dhcp

    Post the results.

  • @crispyoz said in dhcp ipaddress not happening.:

    logread | grep -i dhcp


    i am not able to ping google address.

  • @Nagarjuna-Reddy You can see from the log that DNSMasq is unable to obtain an address range. This means there is no dhcpd on that network. You won't be able to ping google because part of the dhcp response you would receive (if you were getting one) would be to set your DNS and your default route.

    Your Omega is plugged into a router or switch I expect, do you know the IP of that router? Let's assume it is, so to check your network connectivity is actually working, set a static IP on your Omega, like this, by changing your /etc/config/network like so:

    config interface 'wan'
    option ifname 'eth0'
    option proto 'static'
    option ipaddr ''

    Now do service network restart and then ifconfig to check your eth0 has the ip If it does then ping your router, I assume it is something like If that works then ping and, post the results of this.

  • @crispyoz Hi sir,
    still iam not getting ethernet.



  • @Nagarjuna-Reddy What is the IP address of your router? Let's assume it's (check this is correct).


    Post the results.

    If ping times out, then you have a bad connection to your router, check your ethernet cable and if you are plugged directly into a router, many have a LED next to each port, check that it illuminates when you plug in the cable from your Omega.

    Ping works ok, then use this command:

    traceroute -4

    post the results.

  • @crispyoz said in dhcp ipaddress not happening.:

    traceroute -4

    sir my default gateway is this I was added using the following below command.
    route add default gateway eth0
    after vi /etc/resolve.conf // added nameserver
    after added this I am able to ping the google network.
    Thanks for supporting sir.

  • @Nagarjuna-Reddy So it seems the underlying issue is that your DHCP server is either not accessible or is not providing dhcp service correctly. Using static IP is a fix but your IP, routing and DNS should be provided by your DHCP server on your network.

Looks like your connection to Community was lost, please wait while we try to reconnect.