We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Full JFFS2 Partition, I/O error, Trace/breakpoint trap

  • Can anyone help me understand what is happening with the following errors? I cant run python or gpio commands.

    BusyBox v1.28.3 () built-in shell (ash)
       ____       _             ____
      / __ \___  (_)__  ___    / __ \__ _  ___ ___ ____ _
     / /_/ / _ \/ / _ \/ _ \  / /_/ /  ' \/ -_) _ `/ _ `/
     \____/_//_/_/\___/_//_/  \____/_/_/_/\__/\_, /\_,_/
     W H A T  W I L L  Y O U  I N V E N T ?  /___/
       Ω-ware: 0.3.2 b246
    Your JFFS2-partition seems full and overlayfs is mounted read-only.
    Please try to remove files from /overlay/upper/... and reboot!
    root@Omega-19E5:~# python3 ./testing/spi/spi-test.py
    Trace/breakpoint trap
    root@Omega-19E5:~# fast-gpio set 11 0
    -ash: fast-gpio: I/O error

    I have tried removing some files from /overlay/upper/ but am not completely sure what is safe to remove. I have also tried booting into failsafe mode and done firstboot & restart then went through the whole setup process with no luck.

    My dev process involves developing in pycharm on local machine and transferring files to omega to be ran which was working fine, but maybe continually transferring filled up the memory?

    Any help would be great.

  • @eblasband Yor device is full and therefore the file system has been flagged read only in order to prevent corruption of the file system.

    Do a factory reset then start afresh.

    Familiarise yourself with the df command so you can understand your available resources. IoT SOCs have limited resources, you need to manage them diligently. Consider using an SD Card so you can place your files on this file system.

Looks like your connection to Community was lost, please wait while we try to reconnect.