We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

How to kill TCP connection



  • Sir i was running TCP connection after some time suddenly i got TCP connection terminated error, I was checked server_IP that i am able to pinging but the port is not opened. even i tried /etc/init.d/network restart after that also same TCP connection terminated happening.
    The server is End device there port will be opened always. i am using client (IP 192.168.0.200 port 502) what should do now?



  • @Nagarjuna-Reddy Your server may not be checking that the port handle is still valid. Have you tried to restart your server?



  • @crispyoz
    Server i should not restart. that is in some other location. That is an end-device.



  • @Nagarjuna-Reddy if you are trying to connect to a server and that server has closed its port, I'm not sure what you expect to be able to do.

    Have you tried connecting to the server from another device? So you can be sure the issue is not on your device, but actually on the server itself.



  • @crispyoz
    when we restart the end-device it starts working. End-device connected through IP Ethernet.
    using remotely i connected to our onion-board(client device).



  • @Nagarjuna-Reddy I'm confused. Let's use some consistent terminology.

    Your Omega is the "Client".
    The "End Device" is the "Server".

    My understanding is that your Client is connecting to the Server and after some time the Server port seems to be closed. Is this correct?

    You have tried network restart on the Client, but still the Client cannot connect to the Server port, correct?

    You said that if you restart the Server, then your Client can connect to the Server port again. Correct?

    If all of this is correct, it seems the issue is on the Server side.



  • @crispyoz
    All are Yes.



  • @Nagarjuna-Reddy So this indicates the issue is on the Server side. It is possible that your client is causing the Server side to fail, but it is the Server side code that needs to recover the port state. Do you have any control over the Server? What type of app is it running?



Looks like your connection to Community was lost, please wait while we try to reconnect.