We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Omega2 not completing startup

  • I have an Omega2 and a 2+. I am having the same problem with both.
    I can connect initially to the device via wifi and the startup begins. Account, password, and then the search for Wifi. It never finds the local wifi. I have tried in two different facilities. My laptop connects fine in both.
    How long should I wait? More than 30 minutes?

    Skipping the wifi connect and the update, using terminal and wifisetup, in one facility (WEP) I can find the network, then enter the key, but still no internet connect for update. In the other facility (WPK) wifisetup does not find any networks (30 minutes, still searching - laptop seed it fine).

    What am I doing wrong ?


  • @Jim-W Omega2 uses 2.4ghz so you need to ensure your wifi support 2.4. Next you need to ensure your wifi is broadcasting on standard channels. Check /etc/config/wireless for your configuration, also users have had issues with US configuration, here is the standard config:

    config wifi-device 'radio0'
    option type 'ralink'
    option variant 'mt7628'
    option country 'US'
    option hwmode '11g'
    option htmode 'HT40'
    option channel 'auto'
    option disabled '0'
    option device_mode 'apsta'
    option op_mode 'preference'

    Usual issues maybe you need to set the channel to the specific channel of your wifi router, or comment out "option country US"

    Try those and report back your results,

  • Yes. 2.4GHz on channel 6. /etc/config/wireless is as above. Skipped the auto-discovery and used wifisetup. Selected a 2.4 option and connected. I do not know why this was not auto-discovered, but manual setup worked.
    Thanks !

  • @Jim-W That's good news. There could be several reasons discovery is failing, also be careful with setting a specific channel in case your router switches it on you. Channel 6 doesn't overlap with other channels, so if your router is permitting connection on multiple channels it may be that your Omega2 is connecting on a noisy channel and therefore it fails to connect reliably. Depending on your region and the region your router is designed for, the channels vary.

  • Thanks, I did not specify a channel - it's just the current channel of our 2.4 wifi.

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.