We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Original Image openwrt-22.03.3-ramips

  • Another input: If I use the image provided by the image builder for 22.03 then I get the same result i.e. the wifi command causes the system to hang. I thought this'd be an interesting angle just in case I'd something awry when building the image from scratch. I also did a sysupgrade -n to blast away any spurious config.

    I'll try the beta image of 22.03 from Onion now and report back...

  • @huntc Mine hangs for a few seconds then returns. Using the Onion Beta

  • @crispyoz Using the Onion beta now too... Hangs entirely... i.e. same outcome. Hmm.

  • @huntc the wifi command is just a scrip that calls other functions, these are in /lib/wifi/mac80211.sh take a look at thet and see which function is causing the hang, then we can troubleshoot that.

  • @crispyoz I've installed the Omega 22.03 distro again and the WiFi appears to be ok. Perhaps there's something in the kernel or other config that is missing/different from the 22.03 branch...? I'll re-install my distro and try and debug the wifi script as you suggest.

  • OK, I've managed to restore my custom image. TBH I was still having difficulty with the Onion distro also...

    So, back to my custom image, which is pretty close to the 22.03 distro. If I set -x within the /sbin/wifi script then after enabling WiFi and a bit of execution, we get:

    + '[' '!' -f /lib/netifd/wireless/mac80211.sh ]
    root@OpenWrt:/# [  260.011156] br-lan: port 2(phy0-ap0) entered blocking state
    [  260.016854] br-lan: port 2(phy0-ap0) entered disabled state
    [  260.022992] device phy0-ap0 entered promiscuous mode
    [  260.050570] IPv6: ADDRCONF(NETDEV_CHANGE): phy0-ap0: link becomes ready
    [  260.057548] br-lan: port 2(phy0-ap0) entered blocking state
    [  260.063294] br-lan: port 2(phy0-ap0) entered forwarding state

    ...and then it hangs.

  • I should also mention that the above occurs without applying the Onion config. I'm doing a basic wifi enabling on the 22.03 distro.

    I'm also assuming that it shouldn't matter whether there's an actual antenna connected... I don't have a spare at the mo. I can't see why that should affect things though.

  • I began suspecting that I may have a h/w failure somehow. So, I then tried another Omega2S+ and all appears well. I can apply the Onion config to my custom 22.03 image as per my first post here. Thanks for the engagement. I hope that my config here may help others too.

  • @huntc check your power supply is sufficient, starting wifi causes a significant power draw. I just saw your response re hardware, still might be worth checking power is not the issue, just for future reference,

  • @crispyoz Interesting. Thanks. Will do.

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.