We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Default password not working?

  • I just got my onion today, and after reading the https://wiki.onion.io/get-started I try to to use putty on com3 (my serial port being used)
    When I get into the port I see

    =~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2016.02.02 01:18:10 =~=~=~=~=~=~=~=~=~=~=~=
    ar7240: simple_config callback..sc 0, irq 1, ignorepb 0, jiffies 4294904541
    ar7240: calling simple_config callback.. push dur in sec 0
    U-Boot 1.1.4 (Aug 28 2015 - 16:51:26)
    AP121 (ar9331) U-boot
    DRAM:  64 MB
    Top of RAM usable for U-Boot at: 84000000
    Reserving 140k for U-Boot at: 83fdc000
    Reserving 192k for malloc() at: 83fac000
    Reserving 44 Bytes for Board Info at: 83fabfd4
    Reserving 36 Bytes for Global Data at: 83fabfb0
    Reserving 128k for boot params() at: 83f8bfb0
    Stack Pointer at: 83f8bf98
    Now running in RAM - U-Boot at: 83fdc000
    Flash Manuf Id 0xef, DeviceId0 0x40, DeviceId1 0x18
    flash size 16777216, sector count = 256
    Flash: 16 MB
    Using default environment
    In:    serial
    Out:   serial
    Err:   serial
    Net:   ag7240_enet_initialize...
    No valid address in Flash. Using fixed address
    No valid address in Flash. Using fixed address
    : cfg1 0x5 cfg2 0x7114
    eth0: 00:03:7f:09:0b:ad
    eth0 up
    : cfg1 0xf cfg2 0x7214
    eth1: 00:03:7f:09:0b:ad
    ATHRS26: resetting s26
    ATHRS26: s26 reset done
    eth1 up
    eth0, eth1
    Hit any key to stop autoboot:  4  3  2  1  0 
    ## Booting image at 9f300000 ...
       Image Name:   Linux Kernel Image
       Created:      2015-08-28   8:51:30 UTC
       Image Type:   MIPS Linux Kernel Image (lzma compressed)
       Data Size:    772146 Bytes = 754 kB
       Load Address: 80002000
       Entry Point:  8019bd60
       Verifying Checksum at 0x9f300040 ...OK
       Uncompressing Kernel Image ... OK
    No initrd
    ## Transferring control to Linux (at address 8019bd60) ...
    ## Giving linux memsize in bytes, 67108864
    Starting kernel ...
    Booting AR9330(Hornet)...
    Linux version 2.6.31--LSDK-9.2.0_U11.14 (dingyongtian@localhost.localdomain) (gcc version 4.3.3 (GCC) ) #6 Fri Aug 28 16:51:14 CST 2015
    flash_size passed from bootloader = 16
    arg 1: console=ttyS0,115200
    arg 2: root=31:02
    arg 3: rootfstype=squashfs
    arg 4: init=/sbin/init
    arg 5: mtdparts=ar7240-nor0:256k(u-boot),64k(u-boot-env),2752k(rootfs),13184k(uImage),64k(NVRAM),64k(ART)
    arg 6: mem=64M
    CPU revision is: 00019374 (MIPS 24Kc)
    Determined physical RAM map:
     memory: 02000000 @ 00000000 (usable)
    User-defined physical RAM map:
     memory: 04000000 @ 00000000 (usable)
    Zone PFN ranges:
      Normal   0x00000000 -> 0x00004000
    Movable zone start PFN for each node
    early_node_map[1] active PFN ranges
        0: 0x00000000 -> 0x00004000
        Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 16256
        Kernel command line: console=ttyS0,115200 root=31:02 rootfstype=squashfs init=/sbin/init mtdparts=ar7240-nor0:256k(u-boot),64k(u-boot-env),2752k(rootfs),13184k(uImage),64k(NVRAM),64k(ART) mem=64M 
    PID hash table entries: 256 (order: 8, 1024 bytes)
    Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
    Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
    Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
    Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
    Writing ErrCtl register=00000000
    Readback ErrCtl register=00000000
    Memory: 62632k/65536k available (1652k kernel code, 2832k reserved, 420k data, 112k init, 0k highmem)
    plat_time_init: plat time init done
    Calibrating delay loop... 266.24 BogoMIPS (lpj=532480)
    Mount-cache hash table entries: 512
    NET: Registered protocol family 16
    ===== ar7240_platform_init: 0
    bio: create slab <bio-0> at 0
    SCSI subsystem initialized
    usbcore: registered new interface driver usbfs
    usbcore: registered new interface driver hub
    usbcore: registered new device driver usb
    NET: Registered protocol family 2
    IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
    TCP established hash table entries: 2048 (order: 2, 16384 bytes)
    TCP bind hash table entries: 2048 (order: 1, 8192 bytes)
    TCP: Hash tables configured (established 2048 bind 2048)
    TCP reno registered
    NET: Registered protocol family 1
    AR7240 GPIOC major 0
    squashfs: version 4.0 (2009/01/31) Phillip Lougher
    msgmni has been set to 122
    io scheduler noop registered (default)
    Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
    ttyS0: detected caps 00000000 should be 00000100
    serial8250.0: ttyS0 at MMIO 0xb8020000 (irq = 19) is a 16550A
    console [ttyS0] enabled
    brd: module loaded
    6 cmdlinepart partitions found on MTD device ar7240-nor0
    Creating 6 MTD partitions on "ar7240-nor0":
    0x000000000000-0x000000040000 : "u-boot"
    0x000000040000-0x000000050000 : "u-boot-env"
    0x000000050000-0x000000300000 : "rootfs"
    0x000000300000-0x000000fe0000 : "uImage"
    0x000000fe0000-0x000000ff0000 : "NVRAM"
    0x000000ff0000-0x000001000000 : "ART"
    usbmon: debugfs is not available
    TCP cubic registered
    NET: Registered protocol family 17
    802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
    All bugs added by David S. Miller <davem@redhat.com>
    arch/mips/ar7240/gpio.c (ar7240_simple_config_init) AP_RESET_GPIO: 22
    arch/mips/ar7240/gpio.c (ar7240_simple_config_init) JUMPSTART_GPIO: 11
    ar7240wdt_init: Registering WDT success
    VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
    Freeing unused kernel memory: 112k freed
    init started:  BusyBox v1.01 (2015.08.28-08:51+0000) multi-call binary
    init started:  BusyBox v1.01 (2015.08.28-08:51+0000) multi-call binary
    Starting pid 20, console /dev/ttyS0: '/etc/rc.d/rcS'
    ATHR_GMAC: Length per segment 1536
    ATHR_GMAC: fifo cfg 3 01f00140
    ATHR_GMAC: Mac address for unit 0:bf3f0000
    ATHR_GMAC: ff:ff:ff:ff:ff:ff 
    ATHR_GMAC: Max segments per packet :   1
    ATHR_GMAC: Max tx descriptor count :   40
    ATHR_GMAC: Max rx descriptor count :   252
    ATHR_GMAC: Mac capability flags    :   4403
    ATHR_GMAC: Mac address for unit 1:bf3f0006
    ATHR_GMAC: ff:ff:ff:ff:ff:ff 
    ATHR_GMAC: Max segments per packet :   1
    ATHR_GMAC: Max tx descriptor count :   40
    ATHR_GMAC: Max rx descriptor count :   96
    ATHR_GMAC: Mac capability flags    :   4D83
    athr_gmac_ring_alloc Allocated 640 at 0x838cb800
    athr_gmac_ring_alloc Allocated 4032 at 0x838a9000
    Setting Drop CRC Errors, Pause Frames and Length Error frames 
    Setting PHY...
    athr_gmac_ring_alloc Allocated 640 at 0x838cb400
    athr_gmac_ring_alloc Allocated 1536 at 0x83965000
    ATHRS26: resetting s26
    ATHRS26: s26 reset done
    Setting Drop CRC Errors, Pause Frames and Length Error frames 
    Setting PHY...
    device eth0 entered promiscuous mode
    device eth1 entered promiscuous mode
    ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
    Port Status 1c000004 
    ar7240-ehci ar7240-ehci.0: ATH EHCI
    ar7240-ehci ar7240-ehci.0: new USB bus registered, assigned bus number 1
    ehci_reset Intialize USB CONTROLLER in host mode: 3
    ehci_reset Port Status 1c000000 
    ar7240-ehci ar7240-ehci.0: irq 3, io mem 0x1b000000
    ehci_reset Intialize USB CONTROLLER in host mode: 3
    ehci_reset Port Status 1c000000 
    ar7240-ehci ar7240-ehci.0: USB 2.0 started, EHCI 1.00
    usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
    usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
    usb usb1: Product: ATH EHCI
    usb usb1: Manufacturer: Linux 2.6.31--LSDK-9.2.0_U11.14 ehci_hcd
    usb usb1: SerialNumber: platform
    usb usb1: configuration #1 chosen from 1 choice
    hub 1-0:1.0: USB hub found
    hub 1-0:1.0: 1 port detected
    Initializing USB Mass Storage driver...
    usbcore: registered new interface driver usb-storage
    USB Mass Storage support registered.
    **** drop_caches_sysctl_handler: all done timer added ...**** 
    Starting pid 218, console /dev/t
     (none) mips #6 Fri Aug 28 16:51:14 CST 2015 (none)
    (none) login: root
    Password: onioneer
    Login incorrect
    (none) login:

    For user I tried root and for password i tried onioneer but no dice, did i get a board with a bad flash? What do i need to do to get it working? I have tried factory reset already.

    Edit for people who have the same problem, we are the lucky few who got the test firmware.

    The password is 5up

    To reflash the firmware as the test firmware does not have httpd

    @Gabriel-Ongpauco said:

    This is the first time we are seeing this kind of problem with the testing firmware, and we already have a rough idea about how to fix it.

    The general process is as follows:

    set up a TFTP server on another computer connected to your LAN/wireless network
    host an image of the proper Omega firmware on the computer from http://repo.onion.io/omega/images/
    connect the Omega in question to your LAN with the Ethernet Expansion
    point the Omega to the TFTP server via your computer's IP and the image file name to flash it
    This is the rough idea of how it will go, and we are still working on the documentation for it. We will be looking into this more this week.

    Contact the staff (fill out support ticket) They will send you a new omgea that does not have the testfirmware on it.

  • @chris mccaslin you mentioned in our private chat also, that the LED on the Onion is not working. This could indicate a serious HW Problem. As I use MiniDocks i cant verify if it is possible to run a onion just with the "NormalDock's" LED.

  • This is true, but after looking closely were the amber led is on the omega i see a very faint glow of orange when the green light of the expansion dock is on. I get access to the omega through serial so I dont think it's hw. I feel like the flash was put on this device with a diffrent password but I am by far no expert in this type of stuff.

  • So if I get you well, you can reach your omega from serial terminal. But cannot reach from ssh. If this is the case, may be you can look at the /etc/passwd file and paste the output in here.

  • No, I can plug my omega into Serial, I CAN NOT LOGIN UNDER ANY CIRCUMSTANCES (I have tried the username root; and the password: onioneer and onion, and password but nothing works), I can not use any commands, The only way I get that output is if I hold the factory reset button while it's plugged into serial.

    This has rendered my onion omega useless to me.

  • Hi @chris-mccaslin, it seems that you have received an Omega that was flashed with the testing firmware. You can log into the Omega with the password 5up. Do you happen to have an ethernet expansion? You will need that to be able to restore the Omega to the default firmware.

    Please let me know and I will show you how to restore the Omega.

    I apologize for the inconveniences.

  • I did not get the ethernet expansion, AND THANK you 5up was the password!!
    But it looks like the testing firmware's only programs are: alias bg break cd chdir continue eval exec exit export false
    fg hash help jobs kill let local pwd read readonly return set
    shift times trap true type ulimit umask unalias unset wait

    This is very disappointing that I have to purchase the ethernet expansion to flash my omega to use it,

  • @chris-mccaslin said:

    This is very disappointing that I have to purchase the ethernet expansion to flash my omega to use it,

    Do not buy it ... let make you a gift and tell them (onion.io), you will debrick omegas in your area if someone sends it with a prepaid response envelope. Of course with an agreement where fits for both sides (you and onion.io).

    In the end:
    www.onion.io :
    Omega is an invention platform for the Internet of Things. It comes WiFi-enabled ...

    It was not, in your case 😕 ? Or was this a in the Black Friday discount included (Wireless disabled)? Not really mine are ok.

    In my case, the most annoying is not the fact to buy something new .. most embarrassing is to wait so long. To see when your track your goods .. that the customs keep the things back and in the end you get elected to pay 70% taxes for your order. (just my 2 cents)

    Would such a behavior (help out) not be a win win for both sides (community and onion.io)? Could we not save a lot of time this way? And a lot of ... 😠 ?

    I would offer to cover the southern part of Brazil.... just have a small problem ... two omegas with two small Docks 😳

  • @Luciano-S I live in Brazil as well. I was a backer in the Kickstarter campaign, got my Omega with expansion dock + oled display without any problems with customs.

  • @Daniel-Sitnik cool ... what made i wrong? Did you get before or after the impeachment of Dilma 😅

    Somehow money has to get back to the Country, what the corrupt politicians are taking out of it!

    lets talk in the international Shipment Request

  • @Luciano-S.
    Luciano, you are an example to the world, your offer to Chris is a proof that the internet is worth existing.
    I also gave 2 Omega units to a colleague of mine to help him at school with a design project for his classes. I also lend him a box with every Onion interface available as of now and told him whatever you can justify to use in your project Ii will be honored to give the interface(s) to you as well. He is about 24 years old and I remember when I was his age how precious help from the ‘gray haired’ techs and engineers was a gift from heaven.
    I wanted to be sure he would start with one of the most impressive SBC concept now on the market.

    • Code Writing for Microcontrollers
      I am a total admirer and user of ‘Flowcode’ (graphical & object oriented) to write the software for my designs:
      If one day Onion teams with Flowcode to offer an integrated design suite they will be by far the very best design environment on the planet.

    • PCB Design Software
      I now use ‘AutoTRAX DEX’ : https://www.kov.com/ . I tried all the standards and for the price $99US this is by far the best integrated PCB Design Software. Support is like the application; exceptional.

    Luciano you truly understand how happiness exists; create it in others and the pleasure is as intense for the receiver as the giver.

  • This post is deleted!

  • thx robert.
    btw, behind the 3 dots (in header of request, most right side) is a edit function hidden. So, you can edit your requests ... 😉

  • @Luciano-S Yes, but only the original creator of the post can edit it 🙂

  • @Kit-Bishop said:

    @Luciano-S Yes, but only the original creator of the post can edit it 🙂

    Yes in the sense of freedom of expression, keeping the netiquettes in mind.

  • @Luciano-S.
    A new discovery a day is as good as 'an apple a day' ...
    Thanks for the tip I edited the text, looks much better 👏

  • @Boken-Lin i got the same problem but i have an ethernet shield how do i flash it?

  • This post is deleted!

  • @Evan-Green said:

    @Boken-Lin i got the same problem but i have an ethernet shield how do i flash it?

    I guess you got a answer, right? Otherwise here is a Tutorial how to do it:

  • @Luciano-S. yeah got it right took me a while but got it eventually thanks

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.