We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

No wifi and permission denied on serial

  • My onion was working fine on a friend's house but when I got home the onion AP did not apear. I though that it could be some problem with wifi configuration and that I could fix it through serial but when I tried do connect the following apear:

    meh:~ gabrielgiordano$ ls /dev/tty.*
    /dev/tty.Bluetooth-Incoming-Port /dev/tty.SLAB_USBtoUART
    meh:~ gabrielgiordano$ /dev/tty.SLAB_USBtoUART
    -bash: /dev/tty.SLAB_USBtoUART: Permission denied
    meh:~ gabrielgiordano$

    i think he is booting just fine. i tried to reset the onion a few times and nothing changed. I'm using the mini dock.

    pls help

  • Sounds like you might have shut it off while it was updating causing a brick. You might need to reflash it.

  • Looks like you are on a Linux system trying to connect with a serial connection, right?

    If yes try to connect the serial connection with sudo. So you might not get permisson denied.

  • I'm using a mac, but i can try on a linux later. how can I reflash? It wasn't updating. If I do a hard reset it will work?

  • I read somewhere that you need a ethernet expansion to reflash it but I don't have one

  • When you used it on a friends house you just have to adjust your local ip settings that you use the same IP Range as the Omega uses. Not seeing a device in AP mode can be because of troubles with other WiFi devices/ID's.

  • If it worked you don't have to re-flash ..

  • I do have an arduino shield and an ethernet shield for arduino. Is it possible to reflash the onion with this?

  • Primeiro de fazer alguma coisa como "reflash", você precisa saber o que realmente aconteceu ou que esta faltando. Poderia fazer um Factory reset (apertar o botão de reset ate 10 secundos). Assim o Omega fica como vinha da fábrica. Vai demorar um momento ate o Omega volta a trablahar (a luz do led ligado continualmente).
    Depois poderia commeçar com onion.io/getstarted de novo.

    Before re-flashing your system you need to find out what happened and or what is missing. To start over you could try a Factory reset (explanation that he needs to wait till Omega comes back with led continuously switched on, after pressing the reset button for about 10 seconds).

  • the Factory reset made it work again. thanks everybody 😄

Looks like your connection to Community was lost, please wait while we try to reconnect.