We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

nfs mount..

  • Ahh OK then yeah the firmware must be compiled with those driver enabled.
    Have you tried compiling the firmware? There is a post here on how to use Docker and a pre-built image that a community member has built.

    I was able to compile my own firmware and saw the options to include the kernel driver AS seen in the image below. If you can get the Docker image (or other way) to compile the firmware; you could also include this kernel driver in the firmware and flash and test it.

    Below is the Omega2 firmware 'make menuconfig' option showing the nfs file system kernel driver. If you want, I can try to take the defaults and add this driver in and build the firmware. I could then host it on my GitHub and you could download and try to flash it from there. Would just take me a bit of time but BE FORE WARNED that while I'm sure I could get it to compile, and have done it with other OpenWRT builds and boards; I cannot say it won't strand you but making the device unusable. All attempts at this source is to share with the community BUT you take all risks in knowing how, what to do if problems occur.

    Let me know and I can compile for you with some options (if you know them) and the nfs module and you could test.

    alt text

    @Gian-Carlo-Salvati said in nfs mount..:

    @Richard-Berg thansk, but I already installed this package.

    What happens is there is no kernel driver available forthis system.
    Then mount command shows there is no device ..

  • @Richard Berg thanks! I would like if you could do it for me!
    If something goes wrong there is any way to flash the original firmware?

    I will read about docker option too!

    Let me know when you publish the file!

  • @Gian-Carlo-Salvati

    Started to build then I remembered there are Omega2 and Omega2+.
    If you have time before the build of the firmware, let me know which you want.

    If I don't hear back from you before I'm done building the Omega2 (plain) I'll just spin the configuration for the Omega2+ and make you one of each, lol.


  • @Gian-Carlo-Salvati

    Here is the github repo with 2 files: one for the Omega2 and one for the Omega2+
    Choose your version, download and flash.


    BEWARE, however, that I may not be able to help you get back to default firmware if something goes wrong with the flash but I have helped someone recover their Omega2+ from constant reboot due to a bad firmware from Onion.

    If we get to that point, let me know and we can help you with a dock and USB if you have them. If not, you may have to use a TTL2USB adapter and go serially. This would be NO different if you flashed a bad firmware from Onion so while I give you the BEWARE it's something you may have to do eventually, lol..

    Here is the option I enabled from default firmware:
    alt text

  • Thanks a lot!!!
    I dont know how to thank you!
    I will try it!

    Best regards!

  • now it Works! I used Serial connection.
    But I cant connect to wifi.
    I am using this user-guide:

    Any hint?

  • I did connect to my Wifi network, but the signal is so weak now.

    I saw come configurations on this forum that points to ralink driver instead the one that came with the kernel in this firmware...
    Which one is the best?

  • @Gian-Carlo-Salvati


    As for the WiFi driver I'm not sure. I used what was packaged in the Docker image from another user. If by chance you have used Docker the image is pretty straight forward and once you build the toolchain & tools binaries (which takes me about 1 hour roughly on an 6/12 core i7 49230K @ 3.4ghz) it builds in roughly 20 mins thereafter. If not Docker, you should still be able to use Linux and pull the source but you'll have to do some configuration up-front.

    I'm just glad the NFS works but again, sorry on the WiFi šŸ˜ž

  • @Gian-Carlo-Salvati

    Also, below is the driver that came 'stock' setup in the firmware.. If you deduce which one you wish to try let me know and I can attempt to merge in and rebuild for you. Lastly, Omega2 or 2+ just in case we do get to rebuild it for you šŸ™‚

    alt text

  • @Richard-Berg thanks!

    I saw now on my other omega2, the default driver on original firmware is: ralink_eeprom_api , mt76x8, ralink_gdma.
    On /etc/config/wireless the configuration for wifi device is: 'ralink'

    I don't know, but I will test more then I tell you.

    Thanks in advance!

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.