We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Disable AP and set static IP



  • Just got my Omega2+'s, they're working fine.

    As I would like to do a more secure Wi-Fi setup, I am wondering how I can:

    • Set up a static IP
    • Disable the AP and make the Omega a "standard" wifi client

    I have tried to disable the AP from the Onion Console, but that setting doesn't seem to do anything.

    Anyway, as I can easily access the serial console, I would actually prefer to do the above through command-line. I have done a few experiments with the /etc/config/network and /etc/config/wireless files, but I couldn't come up with a fully reliable configuration.

    Thanks in advance!



  • Did you check out the wiki (even if it was made for omega1, similarities are still there) ... i guess there are several hints how to set a static IP.



  • I also have some trouble setting a static IP address

    What I tried and know so far :

    The settings are stored at this location /etc/config/network
    You can find info on the parameters there :
    https://wiki.openwrt.org/doc/uci/network

    I setup a static ip address for interface wwan with option proto 'static'
    I also setup the right gateway and then reloaded the network settings with /etc/init.d/network reload

    The static IP address is there after I reload the config, and I can ping the Omega and from the Omega I can ping my router

    The problem I have is that internet access is not working anymore. I think it might be a DNS issue.



  • I've found the same thing in my efforts to do the same.



  • Has anyone found a solution to this yet?
    I've seen this on several different omega2+ modules now.
    Wifi Client configured with static IP can ping local network, but cannot reach the internet.

    It works fine when using DHCP, though.



  • @Thomas-Jager Please don't necropost, on a 8 year old thread! Just create a new thread and add a reference to the old thread.

    My guess is your DNS is the issue, DHCPD (when you use dynamic IP), also sets your DNS among other things, you can probably fix it by hard configuring the DNS when you use a static IP.

    Try changing the wireless config for sta by adding the following settings:

    option netmask '255.255.255.0'
    option gateway '192.168.1.1'
    option dns '8.8.8.8'

    The gateway and netmask will be specific to your network. After making those changes restart the network using the command "service network restart" or just reboot. If it still does not work then post the output of the following commands:

    ping 8.8.8.8
    traceroute 8.8.8.8
    uci show network
    uci show wireless

    Then set back to dynamic ip (using dhcp) and post the output of the above commands, and also add the command:

    ifconfig



  • Sorry it's a habit to search threads for common issues before posting a question and the similar issue others had above weren't addressed.
    Nevertheless, I had already set those parameters for the wwan interface and it didn't make any difference.
    Here's the output from those commands.

    
    root@Omega-3DA9:/# uci show network
    network.loopback=interface
    network.loopback.ifname='lo'
    network.loopback.proto='static'
    network.loopback.ipaddr='127.0.0.1'
    network.loopback.netmask='255.0.0.0'
    network.globals=globals
    network.globals.ula_prefix='fd1d:48c4:7633::/48'
    network.wlan=interface
    network.wlan.type='bridge'
    network.wlan.proto='static'
    network.wlan.ipaddr='192.168.3.1'
    network.wlan.netmask='255.255.255.0'
    network.wlan.ip6assign='60'
    network.wwan=interface
    network.wwan.ifname='apcli0'
    network.wwan.hostname='Omega-3DA9'
    network.wwan.proto='static'
    network.wwan.ipaddr='192.168.5.88'
    network.wwan.netmask='255.255.240.0'
    network.wwan.gateway='192.168.5.254'
    network.wwan.dns='8.8.8.8'
    network.wan=interface
    network.wan.ifname='eth0'
    network.wan.proto='dhcp'
    root@Omega-3DA9:/# uci show wireless
    wireless.radio0=wifi-device
    wireless.radio0.type='ralink'
    wireless.radio0.variant='mt7628'
    wireless.radio0.country='US'
    wireless.radio0.hwmode='11g'
    wireless.radio0.htmode='HT40'
    wireless.radio0.channel='auto'
    wireless.radio0.disabled='0'
    wireless.radio0.device_mode='apsta'
    wireless.radio0.op_mode='preference'
    wireless.ap=wifi-iface
    wireless.ap.device='radio0'
    wireless.ap.mode='ap'
    wireless.ap.network='wlan'
    wireless.ap.ifname='ra0'
    wireless.ap.encryption='psk2'
    wireless.ap.key='12345678'
    wireless.ap.disabled='0'
    wireless.ap.ssid='Omega-3DA9'
    wireless.sta=wifi-iface
    wireless.sta.device='radio0'
    wireless.sta.mode='sta'
    wireless.sta.ifname='apcli0'
    wireless.sta.encryption='psk2'
    wireless.sta.network='wwan'
    wireless.sta.led='omega2p:blue:wifi'
    wireless.sta.disabled='0'
    wireless.sta.key='<MY_PASSWORD>'
    wireless.sta.ssid='<MY_SSID>'
    wireless.@wifi-config[0]=wifi-config
    wireless.@wifi-config[0].key='<MY_PASSWORD>'
    wireless.@wifi-config[0].ssid='<MY_SSID>'
    wireless.@wifi-config[0].encryption='psk2'
    root@Omega-3DA9:/# traceroute 8.8.8.8
    traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 38 byte packets
     1traceroute: sendto: Network unreachable
    root@Omega-3DA9:/# ping 8.8.8.8
    PING 8.8.8.8 (8.8.8.8): 56 data bytes
    ping: sendto: Network unreachable
    root@Omega-3DA9:/#
    

    And here is the same with DHCP enabled:

    
    root@Omega-3DA9:/# uci show network
    network.loopback=interface
    network.loopback.ifname='lo'
    network.loopback.proto='static'
    network.loopback.ipaddr='127.0.0.1'
    network.loopback.netmask='255.0.0.0'
    network.globals=globals
    network.globals.ula_prefix='fd1d:48c4:7633::/48'
    network.wlan=interface
    network.wlan.type='bridge'
    network.wlan.proto='static'
    network.wlan.ipaddr='192.168.3.1'
    network.wlan.netmask='255.255.255.0'
    network.wlan.ip6assign='60'
    network.wwan=interface
    network.wwan.ifname='apcli0'
    network.wwan.hostname='Omega-3DA9'
    network.wwan.ipaddr='192.168.5.88'
    network.wwan.netmask='255.255.240.0'
    network.wwan.gateway='192.168.5.254'
    network.wwan.dns='8.8.8.8'
    network.wwan.proto='dhcp'
    network.wan=interface
    network.wan.ifname='eth0'
    network.wan.proto='dhcp'
    root@Omega-3DA9:/# uci show wireless
    wireless.radio0=wifi-device
    wireless.radio0.type='ralink'
    wireless.radio0.variant='mt7628'
    wireless.radio0.country='US'
    wireless.radio0.hwmode='11g'
    wireless.radio0.htmode='HT40'
    wireless.radio0.channel='auto'
    wireless.radio0.disabled='0'
    wireless.radio0.device_mode='apsta'
    wireless.radio0.op_mode='preference'
    wireless.ap=wifi-iface
    wireless.ap.device='radio0'
    wireless.ap.mode='ap'
    wireless.ap.network='wlan'
    wireless.ap.ifname='ra0'
    wireless.ap.encryption='psk2'
    wireless.ap.key='12345678'
    wireless.ap.disabled='0'
    wireless.ap.ssid='Omega-3DA9'
    wireless.sta=wifi-iface
    wireless.sta.device='radio0'
    wireless.sta.mode='sta'
    wireless.sta.ifname='apcli0'
    wireless.sta.encryption='psk2'
    wireless.sta.network='wwan'
    wireless.sta.led='omega2p:blue:wifi'
    wireless.sta.disabled='0'
    wireless.sta.key='<MY_PASSWORD>'
    wireless.sta.ssid='<MY_SSID>'
    wireless.@wifi-config[0]=wifi-config
    wireless.@wifi-config[0].key='<MY_PASSWORD>'
    wireless.@wifi-config[0].ssid='<MY_SSID>'
    wireless.@wifi-config[0].encryption='psk2'
    root@Omega-3DA9:/# ping 8.8.8.8
    PING 8.8.8.8 (8.8.8.8): 56 data bytes
    64 bytes from 8.8.8.8: seq=0 ttl=117 time=43.152 ms
    64 bytes from 8.8.8.8: seq=1 ttl=117 time=27.060 ms
    64 bytes from 8.8.8.8: seq=2 ttl=117 time=33.935 ms
    64 bytes from 8.8.8.8: seq=3 ttl=117 time=43.808 ms
    64 bytes from 8.8.8.8: seq=4 ttl=117 time=23.444 ms
    ^C
    --- 8.8.8.8 ping statistics ---
    5 packets transmitted, 5 packets received, 0% packet loss
    round-trip min/avg/max = 23.444/34.279/43.808 ms
    root@Omega-3DA9:/# traceroute 8.8.8.8
    traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 38 byte packets
     1  192.168.5.254 (192.168.5.254)  8.139 ms  3.263 ms  3.386 ms
     2  107-222-2-1.lightspeed.tpkaks.sbcglobal.net (107.222.2.1)  4.638 ms  5.771 ms  4.953 ms
     3  99.164.208.50 (99.164.208.50)  23.434 ms  15.245 ms  7.470 ms
     4  *  *  *
     5  *  *  *
     6  32.130.17.87 (32.130.17.87)  20.985 ms  23.270 ms  34.714 ms
     7  12.255.10.122 (12.255.10.122)  57.814 ms  12.255.10.120 (12.255.10.120)  26.544 ms  12.255.10.124 (12.255.10.124)  31.061 ms
     8  *  *  *
     9  dns.google (8.8.8.8)  20.466 ms  19.858 ms  27.595 ms
    root@Omega-3DA9:/#
    


  • And here's the ifconfig output with DHCP:

    
    root@Omega-3DA9:/# ifconfig
    apcli0    Link encap:Ethernet  HWaddr 88:1E:59:01:3D:AB
              inet addr:192.168.5.186  Bcast:192.168.15.255  Mask:255.255.240.0
              inet6 addr: fe80::8a1e:59ff:fe01:3dab/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:1595 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
    
    br-wlan   Link encap:Ethernet  HWaddr 88:1E:59:01:3D:A9
              inet addr:192.168.3.1  Bcast:192.168.3.255  Mask:255.255.255.0
              inet6 addr: fe80::8a1e:59ff:fe01:3da9/64 Scope:Link
              inet6 addr: fd1d:48c4:7633::1/60 Scope:Global
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:40 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:0 (0.0 B)  TX bytes:7305 (7.1 KiB)
    
    eth0      Link encap:Ethernet  HWaddr 88:1E:59:01:3D:AA
              inet6 addr: fe80::8a1e:59ff:fe01:3daa/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:533 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:0 (0.0 B)  TX bytes:176870 (172.7 KiB)
              Interrupt:5
    
    lo        Link encap:Local Loopback
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:65536  Metric:1
              RX packets:286 errors:0 dropped:0 overruns:0 frame:0
              TX packets:286 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:20014 (19.5 KiB)  TX bytes:20014 (19.5 KiB)
    
    ra0       Link encap:Ethernet  HWaddr 88:1E:59:01:3D:A9
              inet6 addr: fe80::8a1e:59ff:fe01:3da9/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
              Interrupt:6
    


  • @drmoeder Please post your ifconfig when using static ip also output of route command.



  • Here are those outputs using static IP.
    I also pinged the gateway at the end

    root@Omega-3DA9:/# ping 8.8.8.8
    PING 8.8.8.8 (8.8.8.8): 56 data bytes
    ping: sendto: Network unreachable
    root@Omega-3DA9:/#
    root@Omega-3DA9:/# traceroute 8.8.8.8
    traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 38 byte packets
     1traceroute: sendto: Network unreachable
    root@Omega-3DA9:/#
    root@Omega-3DA9:/# ifconfig
    apcli0    Link encap:Ethernet  HWaddr 88:1E:59:01:3D:AB
              inet addr:192.168.5.88  Bcast:192.168.15.255  Mask:255.255.240.0
              inet6 addr: fe80::8a1e:59ff:fe01:3dab/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:9316 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
    
    br-wlan   Link encap:Ethernet  HWaddr 88:1E:59:01:3D:A9
              inet addr:192.168.3.1  Bcast:192.168.3.255  Mask:255.255.255.0
              inet6 addr: fe80::8a1e:59ff:fe01:3da9/64 Scope:Link
              inet6 addr: fd1d:48c4:7633::1/60 Scope:Global
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:28 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:0 (0.0 B)  TX bytes:5768 (5.6 KiB)
    
    eth0      Link encap:Ethernet  HWaddr 88:1E:59:01:3D:AA
              inet6 addr: fe80::8a1e:59ff:fe01:3daa/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:2929 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:0 (0.0 B)  TX bytes:994005 (970.7 KiB)
              Interrupt:5
    
    lo        Link encap:Local Loopback
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:65536  Metric:1
              RX packets:294 errors:0 dropped:0 overruns:0 frame:0
              TX packets:294 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:20510 (20.0 KiB)  TX bytes:20510 (20.0 KiB)
    
    ra0       Link encap:Ethernet  HWaddr 88:1E:59:01:3D:A9
              inet6 addr: fe80::8a1e:59ff:fe01:3da9/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
              Interrupt:6
    
    root@Omega-3DA9:/# ping 192.168.5.254
    PING 192.168.5.254 (192.168.5.254): 56 data bytes
    64 bytes from 192.168.5.254: seq=0 ttl=64 time=11.243 ms
    64 bytes from 192.168.5.254: seq=1 ttl=64 time=6.952 ms
    64 bytes from 192.168.5.254: seq=2 ttl=64 time=10.411 ms
    64 bytes from 192.168.5.254: seq=3 ttl=64 time=4.754 ms
    64 bytes from 192.168.5.254: seq=4 ttl=64 time=5.466 ms
    
    


  • @drmoeder please add the output of the route command. If you set the static ip to 192.168.5.186 does it work? Not sure if you are behind a firewall



  • The output to traceroute is in there. It says 'Network unreachable'.
    I just tried setting static ip to 192.168.5.186 and that also does NOT work.



  • @drmoeder I'm asking for the output of the "route" command, not "traceroute"



  • Oh sorry my mistake.

    
    root@Omega-3DA9:/# route
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    192.168.0.0     *               255.255.240.0   U     0      0        0 apcli0
    192.168.3.0     *               255.255.255.0   U     0      0        0 br-wlan
    


  • And with dhcp:

    round-trip min/avg/max = 19.924/24.932/32.018 ms
    root@Omega-3DA9:/# route
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    default         192.168.5.254   0.0.0.0         UG    0      0        0 apcli0
    192.168.0.0     *               255.255.240.0   U     0      0        0 apcli0
    192.168.3.0     *               255.255.255.0   U     0      0        0 br-wlan
    


  • @drmoeder As I expected there is no default route, so you need to add one, add to your network configuration:

    option gateway '192.168.5.254'
    option netmask '255.255.240.0'



  • I thought I had done that. Am I missing something?

    
    root@Omega-3DA9:/etc/config# cat network
    
    config interface 'loopback'
            option ifname 'lo'
            option proto 'static'
            option ipaddr '127.0.0.1'
            option netmask '255.0.0.0'
    
    config globals 'globals'
            option ula_prefix 'fd1d:48c4:7633::/48'
    
    config interface 'wlan'
            option type 'bridge'
            option proto 'static'
            option ipaddr '192.168.3.1'
            option netmask '255.255.255.0'
            option ip6assign '60'
    
    config interface 'wwan'
            option ifname 'apcli0'
            option hostname 'Omega-3DA9'
            option netmask '255.255.240.0'
            option gateway '192.168.5.254'
            option dns '8.8.8.8'
            option ipaddr '192.168.5.186'
            option proto 'static'
    
    config interface 'wan'
            option ifname 'eth0'
            option proto 'dhcp'
    


  • @drmoeder Add the following to your /etc/config/network

    config route 'default'
    option interface 'wwan'
    option gateway '192.168.5.254'
    option target '0.0.0.0'
    option netmask '0.0.0.0'
    option metric '0'

    Then restart.



  • Still no luck.

    
    root@Omega-3DA9:/etc/config# cat network
    
    config interface 'loopback'
            option ifname 'lo'
            option proto 'static'
            option ipaddr '127.0.0.1'
            option netmask '255.0.0.0'
    
    config globals 'globals'
            option ula_prefix 'fd1d:48c4:7633::/48'
    
    config interface 'wlan'
            option type 'bridge'
            option proto 'static'
            option ipaddr '192.168.3.1'
            option netmask '255.255.255.0'
            option ip6assign '60'
    
    config interface 'wwan'
            option ifname 'apcli0'
            option hostname 'Omega-3DA9'
            option proto 'static'
            option ipaddr '192.168.5.88'
            option gateway '192.168.5.254'
            option netmask '255.255.240.0'
            option dns '8.8.8.8'
    
    config interface 'wan'
            option ifname 'eth0'
            option proto 'dhcp'
    
    config route 'default'
            option interface 'wwan'
            option gateway '192.168.5.254'
            option target '0.0.0.0'
            option netmask '0.0.0.0'
            option metric '0'
    
    root@Omega-3DA9:/etc/config# route
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    192.168.0.0     *               255.255.240.0   U     0      0        0 apcli0
    192.168.3.0     *               255.255.255.0   U     0      0        0 br-wlan
    root@Omega-3DA9:/etc/config# ping 8.8.8.8
    PING 8.8.8.8 (8.8.8.8): 56 data bytes
    ping: sendto: Network unreachable
    


  • @drmoeder try this:

    ip route add default via 192.168.5.254 dev apcli0
    ip route get 8.8.8.8
    ping 8.8.8.8


Log in to reply
 

Looks like your connection to Community was lost, please wait while we try to reconnect.