We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

GPRS connection - how to set up ppp connection on openWRT linux



  • Hi, i would develope a node.js server with onion but i need to connect the onion board with gprs module(sim 900 by adafruit ) for provide a internet connect.

    This is the link for configure serial modem with ppp connection with raspberry pi board:
    https://learn.adafruit.com/fona-tethering-to-raspberry-pi-or-beaglebone-black/setup

    how to configure openWRT linux for ppp connection with serial modem??

    Many thanks



  • @danilo-burdese hi plz use below method for making a PPP internet purpose.

    step1: opkg update
    opkg install chat comgt

    Step2: vi /etc/config/network

    config interface 'hologram'
    option defaultroute 1
    option device /dev/ttyS1
    option apn jionet //jionet place use your network apn
    option service umts
    option proto 3g
    option 'pppd_options' 'noipdefault'

    Step3: vi /etc/config/firewall
    this you have to copy config forwarding above line.
    config zone
    option name 'cellular'
    option output 'ACCEPT'
    option forward 'REJECT'
    option masq '1'
    option mtu_fix '1'
    option network 'hologram'
    option input 'ACCEPT'
    Step4: /etc/init.d/firewall restart
    Step5: /etc/init.d/network restart

    that's it thank you.



Looks like your connection to Community was lost, please wait while we try to reconnect.