We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

help omega2 not working

  • What about using a normal USB smartphone charger as power supply? Can work or would be too much "strong" for the device? Have you already tried (if works)?
    I have some here with 4.8v - 700mA, 5v - 850mA and 5.1v - 1500mA, and I would like to know too before my Omega 2+ arrives. Maybe can deliver proper power to Omega 2 and 2+, mainly during hard processes.
    Sorry I'm novice here.

  • Ok this just gets weirder and weirder it somehow must have been the power supply. When I had it connected via serial and connecting both the GND lines the omega 2 + would hang but powering it directly without serial works. So when using the omega without a dock make sure there is enough voltage and current and that the connections are not loose and start with connecting it only to power. Thanks everyone for your help.

  • @Walter-Filho said in help omega2 not working:

    What about using a normal USB smartphone charger as power supply?

    The Omega2 requires 3.3V. Judging from all the problems that has been reported in this thread, don't even think to try anything else than a good reliable 3.3V.

    Even better, use an Omega2 dock! This will save you a few pulled hair.

  • @fossette Thanks, this got me better, I ordered with Expansion Dock, I hope I won' t have so much headaches.
    And I tried to help our friend, maybe some more mA's or a more stable one can handle the device on with all features. I don't know, I'm novice 😕

  • Need to try again then.
    I've used so far:

    1. USB-Serial powered from usb port of macbook pro
    2. 3A voltage regulator (normally used to power a breadboard with arduino) and powered by power supply
    3. same voltage regulator but powered by regular, 9V battery

    It always stopped at 18-th second, unless I've selected "f" to get to the failsafe mode. Then it was stable (but no network etc).

    p.s. I did not order the docking station as it breaks the whole idea of Omega2 for me - being small. Especially that I can use it with usb to serial (which I have) if I need to connect that way.


  • Answering to myself 😉
    I did test another power sources (including 12V/10A power supply as a source to the 3,3V voltage regulator).
    Everything fails. It doesn't look like power, since raspberry pi 3 works like a charm on all of these power sources.

    I'm a one step from throwing my omega2 through open window....

  • @Marek-Szulen said in help omega2 not working:

    p.s. I did not order the docking station as it breaks the whole idea of Omega2 for me - being small.

    I would really recommend the Omega Mini Dock - it is still pretty small, and to quote from https://www.indiegogo.com/projects/omega2-5-linux-computer-with-wi-fi-made-for-iot#/ :

    Mini Dock

    The Mini Dock provides power to the Omega2, and it allows you to plug in USB devices. It is designed primarily for volume-constrained applications, as well as applications that do not require any Expansions (networking, for example). The Mini Dock has a USB-to-serial chip just like the Expansion Dock.

    This takes care of powering from micro USB and provides serial communication over USB if needed (I generally use a standard micro USB phone charger and just communicate over WIFI)

  • Try adding a decoupling capacitor of 100nF as near as possible to the Omega pins between 3.3V and Ground, and another capacitor of ~10..47µF nearby in parallel.

    Also power wrining must be solid, some breadboard wires can have too much contact resistance, ruining the show even if the power source is ok.

    When you use a linear 3.3V regulator, make sure you use it as recommended in the datasheet (regarding capacitors). Some of these regulators tend to oscillate if not properly damped, which can produce all sorts of weird behaviour in connected chips.

    Don't blame Onion for this - properly providing power to digital circuits is not as simple as it seems, that's why they make the docks 😉

  • @luz I did use capacitors. Nothing helped. I've just ordered 3.3v power supply (I don't have zener diodes or linear regulators to build one now).
    The strange thing is, that the same power sources are working fine with arduino, esp8266 and even raspberry pi. Can't believe, that Omega2 needs more power....

    And I don't blame Onion. Shit happens. Many times I've had issues with firmware that was corrupt.

  • Just like racing cars, fast engines rely on quality fuel. Slower microcontrollers are more flexible regarding their power supply input, but there are still limits in order for their internal timings to be met. When push comes to shove, manufacturers decide to provide their own power regulators, but they need to compromise on size, and boards become much bigger than the Omega(2)(+).

  • @Marek-Szulen Arduino is a 8Mhz 8bit machine, the ESP8266 runs at 80Mhz clock, but the Omega has a 580MHz SoC, with complex i/o subsystems like a 5-port Ethernet switch built-in. The RPi is in the same liga (or above), but it has on-board power regulators. Even the Arduinos usually have their own regulators.

    So it's a fact that a naked Omega is a bit more difficult to power than many of the usual maker boards.
    To compare with other maker boards, you need to think "Omega2+dock".

    But I think offloading power supply (and USB-to-serial) to the docks was a clever decision - it allows the Omega to be really tiny, and really affordable, while providing a lot of High-Tech that can't be home brewed.
    On the other hand, making docks is well within reach of community designs. For example, have a look at what @Matthias-Nowak is doing.

    I've done an application-specific mainboard (with a WS2812 LED output and RS485 interface), and being lazy I found the ready-made Recom R78C3.3 regulator working well for both Omega1 and Omega2. See attached schematics.
    alt text

  • @luz Doesn't seem all that sensitive or difficult to power to me. I just slapped one of the el cheapo, cheap-as-chips, eBay switching-mode step-down modules to it and POOF -- off she goes. Seems totally stable and all.

  • I am having the same problem, but I'm using an arduino as power source. I've already tested with a raspberry too but I'm having the same problem. I believe that the lack of current is causing this. I will try to build a step-down and post here the result.

  • I'm having the same stack trace with a 2 Amp 5v adapter connected to the expansion dock (also tried a usb wire directly to my pc), but I don't seem to have any problems with accessing the web ui or turning itself off. I have yet to connect any usb peripherals.

    [   11.254083] ------------[ cut here ]------------                                                                             
    [   11.258782] WARNING: CPU: 0 PID: 476 at drivers/spi/spidev.c:719
    init_module+0x533c/0x5dec [spidev]()                        
    [   11.649524] ---[ end trace 2720e5d9d588bb52 ]---

  • @joe-lones The spidev-warning just comes from the fact that it's defined in the device-tree table. It's nothing more than some kernel-developer didn't like doing it like that for aesthetic reasons and decided to put the warning there, it doesn't actually affect functionality in any way or form. It literally has zero effect, it's just the same as if you loaded the module after booting the kernel, and the only reason the warning is there is aesthetics. You can ignore it.

  • @luz Yeah, true. I'll try some other regulators, and definitelly, I'll keep an eye on the berrydock (need to figure out, where to get a single board - I'm not the best in making double sided pcb's :)) ! Thanks for tip! 🙂

  • AFAIK the stack trace is just a stupidity in the spi driver - whining not to use generic spi drvier device name. You can either patch the devicetree or the driver, but everything should work. What happens if you press enter on the serial console?

  • @Kit-Bishop
    Everybody suggesting docks but omega2+minidock+shipping expensive than other brand quadcore 512mb ram sbcs, I am getting used to omega which is arrived 2 days ago but first seem its still underdevelopment stage. I figured out power and initial setup issue after 1 day.
    Please use a serial debugger and press f while boot and enter failsafe mode

    command firstboot will bring omega2 to factory settings
    after supplying enough current 3.3v input omega will reset to factory default and you can continue to initial setup prosses.

    At least above worked for me.

    After attemping unsuccesfull wifi connection on initial set up, wifi dissepeared on my omega2 and a checked that /etc/config/wireless file corruped.
    i followed above steps and worked for me.

    please be patien after this
    [ 18.201232] EEPROM:Read from [factory] offset 0x0,length 0x400.

    this takes 2-3 min to pass

  • hi guys, had same issues, the omega2+ was booting up until EEPROM message, then the led would go off. I dont have the docks, just connected via serial with Putty. Managed to fix it by using another 3.3v supply (ams1117). Initially i was using a breadboard power supply and seems like it wasnt providing enough power

  • Hi! I got my omega2 and on omega2+ just few days ago and I have the same issue on both. omega2+ just do nothing after "EEPROM:Read from [factory] offset 0x0,length 0x400.", but omega2 just reboot after this.

    I upgraded firmware to v0.1.7-b142.bin, reset to factory settings with firstboot, but still got the same problem.

    Do you have any suggestion?

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.