We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Onion 2 powered, but no AP?

  • Hi all,
    I received my Onion 2+ a couple days ago and I'm just testing it now. It sure would be nice if the team could update the documentation links on the website to include the link to the Onion2 docs? Following the steps outlined in the docs, I power the device with GND connected and 3.3V on the VIN pin. I can see that the device consumes about 160mAh of power and becomes luke warm, so something is certainly happening. The LED goes green, tuns off, turns on, turns off and stays on. That I presume should indicate that it's alive and working? It's not Amber though and it never turns on any access point that I can attach to.


    Update1: sometimes the LED turns off and power consumption goes down to 62mAh?

    Update2: there is no voltage on the Vout pin. I presume that's not good?

  • Perhaps a power issue. Refer to this thread for further details and comments:

  • I've now tried all the tricks mentioned in that article:

    1. I use my 1A benchtop supply set to 3.3V. That didn't matter, so I change to:
    2. Using a 1A 5V original Apple wall-wart powering a breadboarded AMS1117-3V3. Also doesn't help.
    3. I add 104/47uf caps on the input lines to the Onion2 and a 100uf cap on the 5V input from USB, but still no dice (but more steady power draw)

    I've also hooked up the RX/TX lines to a SiLabs serial adapter and I can see the entire boot sequence (as usual on xNix machines). Every two boot attempts I get this nothing but this after a while:

    [ 3.771396] SQUASHFS error: Unable to read page, block 24877a, size e63c
    [ 3.778210] SQUASHFS error: Unable to read fragment cache entry [24877a]

    When it all goes successfully (without the errors above) I get to this line and then it just stops:

    [ 11.724872] random: jshn: uninitialized urandom read (4 bytes read, 19 bits of entropy available)

    At rare occasions I've gotten past this and then I get stuff like this:

    [ 15.425061]
    do_page_fault(): sending SIGSEGV to S19firewall for invalid write access to 7f1d9fc0
    [ 15.434007] epc = 0044856b in busybox[400000+4a000]
    [ 15.438982] ra = 80004420 in[ 15.442015]

    I'm not saying it's not a power issue, but this just doesn't seem right at all to me?

    I now did a last attempt, hooking it up to an Adafruit Powerboost 1000 backed by a 1200mAh LiPo battery. This thing can certainly deliver enough power. Now I got this:

    [ 1.313797] Process preinit (pid: 1, threadinfo=87c2c000, task=87c28000, tls=00000000)
    [ 1.321816] Stack : 481f404f 00000000 803cbda0 8003ec80 87dfd858 803caec0 87c28000 80430000
    80430000 8003f92c 87c28000 80054004 00000000 87c28000 00000000 87c28000
    00000000 8005406c 80430000 80430000 481f404f 00000000 803cbda0 80430000
    00000000 80061d2c 87df6e00 00000021 87f57180 0006c15a 803cbc40 803cbc00
    481f404f 00000000 803cbc40 803d0000 803cbda0 803cbc00 00000001 00000000
    [ 1.357945] Call Trace:
    [ 1.360426] [<8003edc8>] resched_curr+0xc/0x38
    [ 1.364928]
    [ 1.366433]
    Code: 8c8203e4 8c420004 24420004 <8c430000> 7c630080 14600006 2403ffff c0440000 7c641084
    [ 1.376534] ---[ end trace 17b7aeff46b6b507 ]---
    [ 1.383613] Kernel panic - not syncing: Fatal exception in interrupt
    [ 1.391257] Rebooting in 1 seconds..

    On good boots it'll get longer and I'll see stuff like this:

    [ 15.975925] SQUASHFS error: xz decompression failed, data probably corrupt
    [ 15.982942] SQUASHFS error: squashfs_read_data failed to read block 0x32edd6
    [ 15.990090] SQUASHFS error: Unable to read fragment cache entry [32edd6]
    [ 15.996905] SQUASHFS error: Unable to read page, block 32edd6, size 18c80
    [ 16.003821] SQUASHFS error: Unable to read fragment cache entry [32edd6]
    [ 16.010613] SQUASHFS error: Unable to read page, block 32edd6, size 18c80

    I have to say this isn't very impressive? If the device is THIS unsolid - how can I ever expect it to run my projects?

    Update: for good measure I soldered up a PNMini2A I had floating around: http://www.seeedstudio.com/document/pdf/PNMini2A datasheet.pdf I'm now supplying up to 2A and I have a stupid capacitance setup. It really does not matter. The chip crashes during startup no matter how much power is supplied and as mentioned in the other thread - some get theirs up an working with the cheapest supplies there are.

  • Anyone? Is there a chance that I can revive it or do I request RMA?

  • @Jens-Brynildsen It sounds to me like the flash may be bad or not soldered properly. If it was a power-issue it should've already worked with you having tried so many different methods of powering it up.

  • @Jens-Brynildsen said in Onion 2 powered, but no AP?:

    Anyone? Is there a chance that I can revive it or do I request RMA?

    Did you read the guidelines? ... you will find the link on the top of the page. There it enplanes what procedure you have to do to get HW problem solved.

  • @Luciano-S. Yeah. It took some time, but I found it. The first question I got when they replied was if I could connect it to a CP2102 serial adapter. The SiLabs adapter I used was indeed a CP2102 based design, so I wonder how they thought that what Serial adapter one is using affects this? I also tried with a TTL cable based on PL2303TA. I can't really see how the serial adapter could affect this unless it's connected incorrectly? I only connected GND, RX and TX...

  • Hi Jens,

    Could you please post a photo of your set up with the Omega LED ON?


  • @Michael-Xie48 I have something better - I have a working Onion2! Just like in this thread https://community.onion.io/topic/1159/omega2-almost-doa/2, somebody had done a really sloppy job of soldering the metal cap on my Onion2. Someone had spilled so much solder that the board was shipped out with a short! In the linked picture, you can see that the short is in the top corner, just above the SD card holder. More pictures here http://jcprojects.tumblr.com/post/155454738769/my-omega2-onion-shield-using-a-ams1117-for-33v

    here's my soldering error

  • @Jens-Brynildsen Thanks for pointing out the issue. We apologize for the manufacturing defect and will address the issue with the manufacturer.

  • for curiosity (offtopic)... what functionality does the cover exactly have?

    • Increase the printable space?
    • some cooling effects?
    • hiding hardware ( šŸ˜› ) ?
    • making it nice and shiny ?

    @Jens-Brynildsen , you could may add the info about "electronic shortage" to the title ... so people will do faster their own second quality check.

  • @Luciano-S. It's to reduce RF-interference.

  • This post is deleted!

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.