We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Omega2+ only connects to WiFi once

  • Hey everyone,

    I'm having a strange issue:

    When I first set up my Omega2+, in walking through the initial set up I m able to connect to my WiFi network correctly. I can check for updates, and also install the terminal and file browser modules through the GUI accesssed at <<hostname>>.local. Thereafter, everytime I reboot the Omega2+, I can only access it using it's AP: It does not ever reconnect to my network. It I access the GUI (whilst connected to the AP) I can see that it still has the network saved in the corresponding section, but the checkbox that seemingly enables\disables Wifi capabilities remains unchecked when i check it, switch to another section of the GUI, and then return to the appropriate section.

    Any ideas on why it keeps going into AP mode? I've made sure the network is in range. If I do a factory reset, the issue repeats: I can connect successfuly during the initial setup process but thereafter the credentials are stored but the Omega2+ never reconnects to the nwtwork no matter how many reboots are performed.

    Thanks for any help you guys can offer,

  • @Nelly-Whads Have you actually checked that it's not connected to your network? The web-GUI is broken in many ways and the checkbox for WiFi does not actually reflect whether it is enabled or not -- mine connects to WiFi even when the checkbox is unticked.

  • I can only get my Omega2+ also to act as an AP, it will not connect to my home network. I have tried 1) configuring via the GUI setup routine by pointing my Windows PC browser at after hooking to the Onion via wifi, it times out and 2) configuring via the "wifisetup" command by using puTTY and using the terminal command and 3) trying to modify by hand the /etc/config/wireless

    I'm running the latest firmware for Omega2 that I'm aware of, v0.1.6-b136. Can someone share if running the same version what their /etc/config/wireless file looks like so I can try and replicate the config that way? If that doesn't work I'm thinking of trying to load an earlier firmware on the device. If I do that via a USB stick, are there requirements for the format of the USB stick like being FAT32 format or anything else needed besides the .bin file? I understand I can turn on the Omega2+ while holding down the reset button for a few seconds and bring up the menu to reflash the firmware in puTTY. Thanks!

  • @WereCatf Yes I've gone into my router settings and checked and it doesn't show up there either. Only works immediately after the initial set up. I've also checked cloud.onion.io and that reflects the time on/offline supporting that it never reconnects to the network after rebooting.

  • @John-W Hey John,

    Have you tried connecting to any other networks besides your home network? If not, maybe try tethering off of your phone jut to test it? You might also want to check the frequency of the network, I'm almost certain the Omega's only support 2.4GHz, not 5.0.

  • @John-W

    config wifi-device 'ra0'
            option type 'ralink'
            option mode '9'
            option channel 'auto'
            option txpower '100'
            option ht '20'
            option country 'FI'
            option disabled '0'
    config wifi-iface
            option device 'ra0'
            option network 'wlan'
            option mode 'ap'
            option encryption 'psk2'
            option ApCliEnable '1'
            option ApCliAuthMode 'WPA2PSK'
            option ApCliEncrypType 'AES'
            option ApCliSsid 'REMOVED'
            option ApCliPassWord 'REMOVED'
            option ssid 'REMOVED'
            option key 'REMOVED'
    config wifi-config
            option ssid 'REMOVED'
            option encryption 'WPA2PSK'
            option key 'REMOVED'

  • @Nelly-Whads Hmmm. You did configure Omega's own AP to use a different SSID than your local network, I hope? And your local network uses a different IP-subnet than the Omega's? The Omega uses 192.168.3.x, and if your local network uses the same subnet there could be an IP-collision.

  • You guys are awesome! Thanks @WereCatf for showing me the wireless file from your device, and @Nelly-Whads your suggestion to also try connecting via my phone's hot spot was the final trick to get me on the web!

    So the mention that the Onion Omega2 only supports 2.4GHz means that I need to force my router somehow to only communicate with the Omega2 using 802.11b or 802.11g, and not 802.11n? I have DD-WRT setup on my router, I'm sure there is probably a way to do that then.

  • I looked at my router settings. I found that the encryption type was TKIP instead of AES. Router had the option to change, but was not changing (some bug in the router menu?). Anyway, decided to try changing on the Omega2 the /etc/config/wireless file,

    option ApCliEncrypType 'AES'
    optionApCliEncrypType 'TKIP'

    I also changed the settings in the file to match my router settings instead of my cell phone's wifi hotspot.

    ... and rebooted. It's a beautiful thing, now it connects to my router no problem. This was likely my main issue all along. Thanks again for your help here on the forum.

  • @John-W said in Omega2+ only connects to WiFi once:

    So the mention that the Onion Omega2 only supports 2.4GHz means that I need to force my router somehow to only communicate with the Omega2 using 802.11b or 802.11g, and not 802.11n? I have DD-WRT setup on my router, I'm sure there is probably a way to do that then.

    No. 802.11n can use both 2.4GHz and 5GHz and, in fact, all 802.11n compliant devices have to support it on the 2.4GHz band. The 5GHz band is optional.

  • @WereCatf Yeah I've made sure the SSID's are unique. As for the subnets, the Omega is on stock (192.168.3.x) and my router is on 192.168.0.x. It does initially connect successfully but it just refuses to reconnect after a reboot. I'm going to be visiting some friends for the next little bit so I'll give it a try on some other networks and see if that works.

  • Success! The CLI proved to be a lot more robust at setting things up - it reconnects successfully on reboots now

    Cheers guys

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.