We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Omega2+ not starting up

  • I've just received my Omega2+ with expansion board and followed the Get Started instructions to connect it to a Windows PC via a micro-USB lead, but quickly hit some problems.

    The LEDs on the expansion board and on the Omega2+ don't light up at all when power is applied.

    I can see the Omega2+ write this out to the serial console using Putty on my host PC (115200 8N1):

    Board: Onion Omega2 APSoC DRAM: 64 kB
    relocate_code Pointer at: 7ff70000


    This photo shows the Omega2+ is connected via COM5 because it's connected via a powered USB hub. It connects via COM3 when connected directly to the host PC.

    Linux does not start up and the AP is not visible using a WiFi analyzer.

    I've tried with different USB leads connected direct to the host PC and via a powered USB hub (which incidentally powers a Particle Photon, Olimex JTAG programmer and Logic Analyzer just fine), but I always get the same result.

    The Omega2+ is plugged into the expansion board correctly as shown below.




    I've checked the 5V and 3.3V power lines on the header socket with a digital meter and they are present. The RF screen on the Omega2+ does get warm but I would expect that.



    Can someone tell me why it's not booting up?

    Edited 24/12/2016 - added a couple of more photos to show the both rows of pins inserted into the headers and one of underneath the Omega2+ to show that no pins have folded inside underneath the board.

  • Did you try a other USB cable 2? I had some issues with usb cable not working fine (Omega1).
    You just show one side of the omega, on the other side it is also nicely in the socket?

    Please check out the link on the top (guidelines), if you do all the points there you probably got defective hardware ...

  • @DrWheetos What is strange is that you received an Omega2+, obviously in the photo and as you mentioned in this post. However, the first lines mention 64KB DRAM instead of 128MB. The next step would be UBOOT, followed by Kernel log messages. Would this perhaps be a case of the bad firmware flavor flashed into this Omega2+?

  • @fossette I doubt it's firmware, I'm more likely to believe it's hardware. Bad/poorly-soldered RAM. The SoC most likely already has 64KB SRAM, but fails to initialize external RAM.

  • @Luciano-S. I've added a couple more photos to show the pins on both sides of the Omega2+ board have been inserted correctly into the expansion board. There's also a photo showing the inside of the headers to show none of the pins have folded back underneath the board.

    I'll try some other USB cables today and see if that makes any difference.

  • @fossette Good spot @fossette. An Omega 2 Plus should have 128MB of RAM memory. Wondering if this is on the board as 2x64MB chips and one of them isn't responding. Maybe the bootloader can't complete it's memory integrity check, on the assumption it does one.

    Further update:

    • I've tried today with all the USB A to micro USB cables I have (about 7 of them) and I get the same result with each. At least the Omega2+ is getting power and I'm seeing output on the console so that proves it's powering up and it can talk to my host PC.
    • I know that sometimes a device may not power up properly if it can't get enough current from its power supply so I tried powering the expansion board from a 5V 2A wall plug supply. The LEDs still don't light up so I'm assuming it's still not completing its bootup process.
    • I haven't tried powering the expansion board via its USB A socket yet because I don't have a suitable USB A to A cable to hand. But I haven't seen anything in the Getting Started guide to say this would be an alternative way to power the Omega2+ anyway.

    Thanks for the advice so far. Really looking forward to playing with this due to its tiny size.

  • @DrWheetos said in Omega2+ not starting up:

    Wondering if this is on the board as 2x64MB chips and one of them isn't responding.

    No. It says 64KB, not 64MB.

  • @WereCatf Ah, well spotted. Just guessing but maybe one of the address lines isn't connected correctly, or a solder bridge between pins. It's all under the cover so can't see.

  • @DrWheetos Have you got this problem sorted out? I have exactly the same problem with you.

  • Hi @Wai-Weng-Kong Unfortunately, no the problem has not been sorted. I logged a support ticket to get advice about how to resolve it but Onion just closed the ticket saying it would be resolved through the community site. Onion has reopened the ticket for me but has not provided any suggestion of how to get it working. So at the moment I have a faulty Omega 2+ that is sitting on my desk gathering dust. A nice welcome to my first kickstarter reward!

    I'm pleased someone else has the same problem as me, in that it's not an isolated problem, but I'm sorry you're in the same boat as me šŸ˜Ÿ. I hope this spurs Onion to suggest what to do even if it's a return.

  • W H A T W I L L Y O U I N V E N T ?

    Nothing! My device won't boot....

    Board: Onion Omega2 APSoC DRAM: 64 kb

    relocate_code Pointer at: 7ff70000

    Get out the hot air gun...and a SPI Flash writer.

    It likely just has the wrong Das uBoot installed.
    As in the bootloader code for a device with 64M RAM.
    A small but important difference

    Or maybe just send it back?

    Shouldn't it say "relocate_code Pointer at: 87f60000" ?
    Mine does šŸ™‚

    Of course it could be the RAM chip ... but you would need some hot air to fix that problem as well.

  • @Larry-Pinney Can't just return it without a returns number.

    I stated on my support ticket that it could be the wrong firmware but haven't had any response from Onion about the issue at all.

    Note that my board says:
    Board: Onion Omega2 APSoC DRAM: 64 kB
    but yours says:
    Board: Onion Omega2 APSoC DRAM: 128 MB

    Yours is reporting the correct amount of DRAM but I've got as much as a 1980's 8-bit CPU šŸ‘Ž.

  • It should report this :

    Board: Onion Omega2 APSoC DRAM: 128 MB

    relocate_code Pointer at: 87f60000

  • Same problem here :
    Board: Onion Omega2 APSoC DRAM: 64 kB

  • @fossette That was what I got using the serial console on boot

    Here all the boot sequence :

       ____       _             ____ 
     / __ \___  (_)__  ___    / __ \__ _  ___ ___ ____ _ 
    / /_/ / _ \/ / _ \/ _ \  / /_/ /  ' \/ -_) _ `/ _ `/ 
    \____/_//_/_/\___/_//_/  \____/_/_/_/\__/\_, /\_,_/ 
    W H A T  W I L L  Y O U  I N V E N T ? /___/" 
    Board: Onion Omega2 APSoC DRAM:  64 kB 
    relocate_code Pointer at: 7ff70000 

    And then... nothing

  • @Johan-Charpentier The next line you are supposed to have is flash manufacture id followed by the id. Since you don't have it, I suspect something is wrong with the flash IC itself. I recommend that you follow the RMA procedure with Onion. But first, make sure that your Omega2 is adequately powered.

  • No, not the flash, the DDR2 RAM, or more likely the connections between that and the SoC. It's crashing at the point where it tries to move itself from Flash to RAM - that's what the "relocate_code Pointer" is about. And it's happening after quite obviously not finding the populated DDR2 size.

    If the flash were completely bad, you wouldn't see the initial banner, or really any sign of life at all, except (with a scope) ongoing traffic on the SPI lines as it tries and repeatedly fails to find some code to boot.

  • @Chris-Stratton I don't quite know why you had been voted down, because you are correct: 1) The U-boot loader resides on the SPI-flash, and the Omega2 wouldn't even be able to get that far, if the flash was broken or soldered poorly. 2) The fact that U-boot only reports 64kB RAM instead of 64MB quite clearly spells out exactly what the problem is: the SoC has 64kB built-in instruction-cache SRAM, but it clearly cannot initialize the external DDR2 RAM.

    All this is to say: if U-boot reports only kilobytes of RAM available, not megabytes, the DDR2 RAM is bad or not soldered down properly. You could possibly reflow it, but it's a BGA-package and those are not easy to solder down even with proper tools. The other, recommended, option is to request a replacement from Onion.

  • I'm the OP and have followed the RMA procedure to the letter but have had no response from Onion other than to close my support ticket saying it will be resolved by the community. I got the ticket reopened on 28th Dec and it's still open with no response so far. Please Onion, a month has passed and I've had no advice from you or the community how I get my device running (I don't have solder reflow capabilities, besides it will invalidate any warranty with you). There's at least 3 of us now that have the same problem @Johan-Charpentier @Wai-Weng-Kong . Help please...

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.