We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Omega2+ probably DoA

  • I received my Omega yesterday and I have not yet been able to power it up. I bought the Omega with the Arduino dock 2. The dock has a blue LED that lights up when I connect it to a power supply. However, the amber light on the Omega2+ never lights up. The board becomes lukewarm but no AP shows up. I have tried different power supplies but nothing helps. I can see that the dock supplies the Omega2+ with 3.34V but there doesn't seem to be any power at the VOUT pin. Is this a broken board or can I still get it to work somehow?

  • In my Omega2+ board, Vout Pin is left open circuited thus no voltage is measured.
    Please check the module itself current consumption first to see which state the board is in.

  • I do not have the equipment to check the power consumption. I have a multimeter but have to mess up a usb-cable to be able to check the amperage goinging through to the O2+.

  • @Tobias-Malm140 As far as I understand, the Vout pin is not a general power output, but specifically meant to power the ethernet transformers. It is switched on by the system only when the ethernet port has to be active, and is off otherwise to save power.

    On the Omega expansion dock schematics, this signal is accordingly named NET_POW.

    You can see how it is used in the ethernet expansion shield schematics.

    As we don't have the schematics of the Omega2 yet, I can't be sure - but from the datasheet of the MT7688 I would assume that Vout is connected to pin AVDD33_TX_P0.

    So not seeing any voltage present on Vout is not necessarily a sign of the Omega not working, but just that it has not (yet) switched on the ethernet.

    The case of @ccs-hello seems different, it appears his Omega2 actually has a part missing, so Vout is not connected physically to anything. Most likely, a ethernet expansion would not work correctly with his Omega2.

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.