We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Two Omega2+ devices having issues (wifi, passwords, no terminal)

  • I've got two Omega2+ devices having the same issues, purchased with a single Arduino 2 dock. Both were able to turn on and I could connect via wifi. After going through the setup process, both had to be physically unplugged because the LED wouldn't turn off. After turning both back on, they are experiencing the exact same issues:

    1. Bad connection to my home wifi network. when trying to ping, I get 'ping: sendto: host is down errors from OSX and Destination unreachable from W10. I don't see an option to manually configure the ip address using the web client.
    2. I also can’t turn off the built-in AP mode. Probably a good thing in this case but pretty irritating as I’d rather not have that running. Unchecking the box and trying to save does absolutely nothing.
    3. I also can’t connect to the terminal app in the web client to try & get in and change things myself. The icon either never stops spinning or it disappears and nothing comes up.
    4. Changing the default password does nothing; I could still log in using the web client as root/onioneer no matter how many times I tried changing. I even tried putting the ‘current password’ as something completely random and still got the ‘password changed successfully’ message.

    What am I supposed to do here?

  • for point 3 as i was reading in other requests, on omega2 you have first to install the terminal ?! before you can use it.

    And generally for me it looks like your installation is not completed. If it would it would save the changes. So i propose to connect over serial/ssh and do the configuration in terminal mode.

    If this not works i would do a factory reset ...

  • So last night I was reading and playing around and here's what I came up with:

    1. I connected to one of my units via SSH using its AP and manually re-flashed the firmware version that the unit said it was running (omega2p-v0.1.6-b137.bin, though there are newer versions listed, but I didn't want to take a risk). After this, I was able to use the wifisetup command and it connected to my home network without a problem.
    2. I tried unchecking the button again in the web interface and it broke the connection to my normal network 😞 It also didn't turn off the AP function. "re-enabled" it and my home network connection started working again. For now I'm gonna leave it alone, I was able to change the SSID and password via the web interface so it's at least secure to me now (the web interface didn't work for anything before, basically.)
    3. Before, I wasn't even able to install the terminal app using any browser, but this time I was able to install it and actually use it...just not in Safari. Even after installation, it still just spins in Safari, despite loading in Chrome, Firefox and Edge. Webcam and Editor don't do anything when I click in Safari either.
    4. Changed it using ssh via the passwd command. Don't need to change it again, so I'll just list this as a bug.

    So for right now the moral of the story seems to be: learn to love the CLI and ditch Safari, haha!

    New Questions:

    1. What are the newer versions of the firmware (0.1.7+) on the repo, are they early or should I install the latest version? I haven't done anything really with these units yet so there's no personal data to erase, would they help with any of my issues when I go to reformat my other unit?
    2. Even though I'd rather turn it off, does having the built-in AP running consume enough resources to bother?
    3. Assuming connected to a USB power source, what amperage do I need to provide to be safe with a single unit?
      Looking forward to tinkering with these things!

  • administrators

    For the Console issues, can you please create issues on the Console Github issues page? (Separate issues for each point pls)
    Using Github issues makes it a lot easier for us to track and prioritize our work.

    Regarding your new questions:

    1. Newer versions will have bug fixes and new features - we will be adding to the documentation explaining this and also publishing a changelog of the different versions soon, stay tuned
    2. It shouldn't be too resource intensive especially if no clients are connected
    3. 500mA will be enough, it doesn't usually draw more than 200mA

  • Lazar,
    Will do! Glad to help 🙂

    Re: your answers:

    1. The changelog will be great. I was mostly curious because when using the Console and cli to check my firmware version, both said I was on the latest version (at the time I posted) but there were newer versions on the repo. I updated one of my units to 0.1.7 b140 today (no problems at all) and when running the Console it still sees b139 as the latest version. Both currently see b139 as the latest version, I guess I'm ahead of the curve!
    2. Sounds good, I'll let them both be for the time being. I've got new SSIDs and complex passwords for both of my units.
    3. Perfect; I've got a dual-500mA usb wall adapter I'll repurpose for my units.

    Thanks for the reply!

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.