We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

I Might Be Back .....

  • When Omega3 comes out ! So far Omega2 + gives me NO joy! It did kind of work. But now no Wi-Fi and won't stop booting. Can't even talk to it in Serial ! And Orion IO Help Desk never responds to any new questions, except with a "Being Processed". Days and days go by and I see nothing. I need a replacement for the Omega2 +. It doesn't work any more. All I did was put a wrong entry into the AP configuration, and then it stopped working. I tried everything suggested.


  • I do understand your anger ... but pleas check out the link on top of page and do what they ask for. If needed you will get your replacement. Just do the procedure they ask for.

  • I do have 2 tickets waiting to be processed, one created on Jan 5 and one on the 9th relating about the same issue. I just wish someone would reply and I could try something they suggest. I guess I'll just wait for a while. Thanks

  • @Don-DeGregori said in I Might Be Back .....:

    I need a replacement for the Omega2 +. It doesn't work any more. All I did was put a wrong entry into the AP configuration, and then it stopped working.

    You messed up the configuration and you want a replacement for the whole device? It's your own failure, not theirs, and they are not obligated to just hand out new hardware to you. Kind of like driving a car to a tree and demanding Volvo to give you a new car.

    That said, unbrick your device by following instructions at http://community.onion.io/topic/1154/omega-2-usb-firmware-install-after-brick-resolved instead.

  • I bought 3 of them and so far I am not impressed at all..

    the graphical interfaces doesnt work at all.. cant change anything or turn off AP or change passwords even..

    So I'm stuck with a rogue wireless access point on my network that I cant disable or change passwords to..

    Cloud devices are always offline and doesnt work..

    The header pins are non-standard, so they dont fit on breadboards and you have to buy special conversion boards..

    Doesnt have onboard power supply, you have to build external 5v supply..

    in general, nothing I have tried works and these are 3 little bricks in their box and will remain there until the alpha software has been fixed..

    I didnt expect flawless, but I also didnt expect that nothing wont work... Shipping pre-alpha software and giving people a frustrating experience is not cool..

    Onion staff are also NOT bothering to monitor or reply on bugs being filed on Github..

    Its like everything came to a standstill at some point and they rushed to get the hardware out and forgot about the rest..

  • Seams to be that you are definitely not a "Tony Stark" šŸ˜‰

    And maybe next time, you should read the Forum before buy something. About the socket we discussed this already because of omega1. Some made their own breadboard adapters etc.

    Sorry, but a power supply has never been a part of the mother board! They always have been separate ore external units.

    So if you want that we not ignore you, you could start with one of your omegas and fix step by step. We will be here to support ... and we do this for free as a part of the community.

    Take it easy, but take it!

  • @WereCatf I was able to get it working again, but now I have other things to do and won't be back for a while. Like Koos says all the Omega's are still not out of Alpha yet. The documentation is fair, but very hard to follow. I appreciate all the hard working geeks and hopefully their efforts will payoff in a better product someday. Back to Arduino or Pi. Like good wine from the barrel, both have matured and just work. I'll just watch Omega from the sidelines and say, "I'm OK, you're OK." Don't need another one. Good Luck to all.

  • @Luciano-S. There was not much of a forum when we backed these things on IndieGogo..

    I tried posting issues to GitHub, i.e. the proper SDLC way of filing bugs against software.. but nobody has bothered to respond..

    You seem defensive without addressing any of the issues..

    Why is the web console not working at all?

    why is the cloud devices not working at all?

    why can I not disable the AP or change its settings ?

    why does the SD card slot not work at all?

    You shipped a pretty cute and really awesome piece of hardware, but without the software/firmware and cloud services in place, this thing is useless..


  • I'v actually been having really good luck with the Omega2. AP mode works well, STA mode works great. Accessing the Internet via wireless works well. Serial console works well. Setup went smoothly. Web UI is functional. Cloud access doesn't work yet. I'm not very knowledgeable of WRT so there are things I am used to in a typical Linux that are missing. But so far so good. I am supplying the device with ample power šŸ™‚

  • @dklinkman said in I Might Be Back .....:

    I'v actually been having really good luck with the Omega2. AP mode works well, STA mode works great. Accessing the Internet via wireless works well. Serial console works well. Setup went smoothly. Web UI is functional. Cloud access doesn't work yet. I'm not very knowledgeable of WRT so there are things I am used to in a typical Linux that are missing. But so far so good. I am supplying the device with ample power šŸ™‚

    In Omega2 Docs, under First Time Setup, Using Setup Wizard,
    under the bold word Mandatory, showing 2nd picture. What did you put in? I could not find OnionWiFi in the drop down. All I could see was my router, and 2 or 3 other wireless routers in the area. This is an example of confusion.

  • @Don-DeGregori You were supposed to connect to your wireless network during that step. The OnionWiFi in the example is just that: an example of their wireless network.

  • So their wireless network is named OnionWiFi. Not very typical at all for the average first time user. I did however use my own SSID before, but then got in trouble down the line. Retracing my steps and entering what's happening in Notepad.

    OK I think I got everything working so far again except Terminal, Editor, Cloud, and AP (I'm afraid of it!) Think I'll let the whole thing sit for a few days and just play with it. Shut it down, bring it and make sure it doesn't have a mind of it's own.
    BTW, it's working on an open router right now. I guess it doesn't like my older Netgear router. It's WPA-TIRK. Would like to secure it again. Any ideas?

  • administrators

    Right... we didn't realize connecting to our office OnionWiFi network would prove to be confusing!
    We'll work to fix that!

  • Yesterday Omega was working pretty good. I had to open the wireless on the router. I brought it up from cold start at least 5 times. Fast and smooth. All settings remained the same Console opened no problem. Didn't install Editor, Terminal, or Cloud. Didn't enable AP. Not sure if I should. Well this morning I thought it would come up right away. It didn't. Here's the setup. Windows 10 PC. Has built in wireless, but connected by LAN to open router. Omega right beside it and connects to it. Turn on PC, And look at wireless connections. Then power up Omega. Blue LED on, in few seconds amber flashes, after minute amber solid. Now see Omega-(my ABCD) icon. Click on Connect. Never connects by itself. Why? In a few seconds It's connected. Then use Chrome and input Console comes up, but had to do it twice? From then on it was a pain having to try this and that to make them appear. Like an old car warming up. Never any error messages. Me kind of bit-banging till Omega decided to fully wake up. From then it's OK, like yesterday. Who knows what problems I'll see if I close the router. So I leave it open.

    I think people like me get trouble and don't know what to do and start fooling around. Soon Omega may become a brick. Omega2 + is not a no brainer to me yet. In a month, I'll fire it up again. Maybe the baby will be running by then.

  • Just put router into WPA-TIRK from None. Now not getting Omega to do it's thing like before with None. Can't do Firmware Update in Console. Wheel keeps spinning. What am supposed to have in Wi-Fi Access Point Setup in Console and should AP mode be enabled? This is when I have router in WPA-TIRK.

  • I think Omega2+ should be renamed Erratic2+. Every time I fired it up, I never know what to expect. I'm 79 and this experiment is the biggest time waster. My time is valuable. I'm done. I give Onion a month to fix 90% of the problems or I'm going to talk to Kickstarter or Indiegogo. Onion: You need to hire 100 good guys and get it done.

  • Don,
    If you can turn off your wifi security and get the omega connected to the internet, I would recommend trying to do a manual firmware flash using the latest firmware update. It has cleared up a lot of the weird issues I was having. I did the firmware update, then a factory reset, and my unit has been working really well so far.
    I get the frustration but just in the past two weeks the documentation has been greatly expanded, we're getting new firmware which is fixing issues, and the devs are getting more involved on the forums. It's a new unit, have patience! It's the nature of a kickstarter šŸ™‚

  • @cusackph Thanks for being positive. I'll give your suggestion a go in a few days. I think one problem causes another. It's really frustrating to start the Console and see the gear turning and turning and nothing, And then I look with something else and then go back to Console, all of it comes up in a second. What could I have done to "fix" it? And I see the wireless connection just break with no apparent reason. And then I re-connect, but that doesn't do any good unless I start all over. And then I see something strange I never have seen before. And why does it quit with router encryption. And then all the info I filled out in the Console disappears. The AP Setup in the Console will show one thing and then another. The worst is not knowing the meaning of WHY this is happening. Like a big plot against me. šŸ˜–

  • I totally get that. My suggestion is to just take things one step at a time. I'd say first, leave your wifi open and get the latest version of your firmware installed using the instructions I linked. Don't try to do it through the console, SSH in and do it that way.
    After that, figure out why your unit won't connect to your wifi connection. I think I remember seeing that you were using TKIP for security, which may be the problem. Could you switch it to AES without any problems? Like, are there any devices you own that need TKIP? I use AES and have everything from my laptop to old Kindle connected with no problems.
    Regarding the web console, it's definitely still a bit buggy. Try using Edge on your windows 10 box. I have an apple laptop and most things in the console don't work at all in Safari so I use Firefox.

    What dock/expansions do you have?

  • I decided to write a step by step of what I see trying to bring up the Omera2+. The latest firmware is now used: 0.1.8(b145). Downloaded and installed via PuTTY, not the Console. Followed: Manual Firmware Installation in Omega2 Documentation.

    Omega2+ and Power Dock Notes
    Router not Secure, Open

    1. Switch off, power connected, charge LEDs flashing.
    2. Switch on, blue LED on, amber LED solid, then flashing.
    3. After minute amber LED solid.
    4. See Omega-9ED7 Secured, comes up very slow and not connected in PC tray.
    5. Finally click on Connect.
    6. Now see Omega-9ED7 Connected, secured.
    7. Open PuTTY, see Linux prompt, login root, password onioneer, Firmware says 0.1.8(b145)
    8. Open Chrome,
    9. Console opens, but have to login. Sometimes entries are already filled in
      root, onioneer
    10. Click on Settings.
    11. See, my Wi-Fi network.
    12. Click on General Settings.
    13. See Omega Name Omega-9ED7 and my Timezone OK.
    14. Nothing in Security Settings.
    15. Click on Wi-Fi Settings.
    16. See NETGEAR 3 times, and 2 unknown icons with checkmarks. Enable Wi-Fi checked.
    17. Click on Wi-Fi AP Settings.
    18. See Omega-9ED7, WPA2, onioneer, in correct locations.
    19. Didn't click Configure AP. Many times I see root in SSID location and onioneer in Password. I don think this is correct. I put in in Omega-9ED7 and 12345678.
    20. Click on Firmware Upgrade.
    21. Firmware says 0.1.8(b145), but Latest Firmware says 0.1.7(b139), No Upgrade required.
    22. Wi-Fi still connected as in Step 6. This would disconnect. Much better now.
    23. Did not try any Tools in Console.
    24. Did shutdown by closing Console and switching Omega off.

    It seems there is a bad relationship between login and password not filled out automatically, root and other entries in Wi-Fi Access Point Setup incorrect, and Wi-Fi disconnecting. However, improved over 0.1.7(b139). Don't know results when router is returned to secure. I think timing between processes in the source code is part of many problems. Plus operator error. šŸ˜ž

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.